4

I am stuck on the Companions questline. In my journal, "Proving Honor" is marked as completed, but the top objective "Return to Jorrvaskr" isn't filled in, so it may be bugged. The Silver Hand quest has not been started.

When I talk to any of the leaders, they say "Didn't Skjor already give you a job?" or something.

I went through all the misc objectives that had to do with killing bandit leaders and none of them were related to Skjor (I finished them and the bounty collection was always someone else).

Could this have anything to do with another questline (e.g. civil war) not being complete?

  • Sounds like a bug, have you tried fast travelling away from Whiterun and going back. It might resolve the issue. if you're on the PC you can probably use console commands to get you back on track. – wr4ith Jun 14 '13 at 5:46
  • Yes, I've tried fast travelling and even doing other quests in the meantime. – Daniel Jun 28 '13 at 3:32
1

I have had this also. I think it's a glitch rather than a bug. For me, it was that I hadn't completed one of the radient quests, namely Animal Extermination. I thought that I'd picked that one up at a random innkeeper, not the Companions. Once I completed that quest, the questline went on as usual.

The problem for me was to try to filter out what specific task I'd been given since quest descriptions sometimes aren't completely clear as to who gave it to you.

  • I already looked up the quests on the UESP wiki and didn't see any in my journal (e.g. Animal Extermination, Trouble in Whiterun, etc.). – Daniel Jun 28 '13 at 3:31
-1

Do a quest given to you by another member of the companions, such as Aela.

  • Aela was included when I said "any of the leaders". She says that Skjor already gave me a job. – Daniel Jun 28 '13 at 3:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.