13

I have a steam version of torchlight 2, and this started happening when I installed and then removed some mods. Each time I'm starting torchlight I'm greeted by the following message:

error

After this games start as usual. I would like to have cloud sync enabled. I tried disabling and the re-enabling it, I tried backing up the save files and removing them, these did not help. Reinstalling Torchlight 2 did not help either.

Is there any way to fix this and keep the cloud sync?

1
  • If you looked for the answer to this question on a phone or different computer - check to make sure your internet is working on the computer that has this problem. (Obviously this doesn't apply to OP, but is useful for people like me who come across this question because they weren't connected to the internet.)
    – Pro Q
    Sep 4 at 22:56
6

Here's a great way to fix this without nuking Steam. My downloaded Steam Cloud files got out of whack.

In my case, I quit Steam, I found my Steam Cloud save folder on my PC for the game in question, and nuked it. Then I relaunched Steam and relaunched the game. It fetched fresh data from Steam Cloud and then synchronization worked again.

I used SteamDB to find the AppID for my game, then deleted that folder in the following path.

C:\Program Files (x86)\Steam\userdata\[MY STEAM USERID]\[APP ID]

Problem solved!

2
  • Worked for me in Nov 2020. Thanks!
    – kcstrom
    Nov 28 '20 at 15:12
  • This worked for me in Aug 2021. However, I did have to try several times. Watching the [APP ID] folder showed that files were being downloaded (slowly). Steam would give up after a batch of 6 - 9 files, but eventually all files were recovered and the game started. Aug 20 at 6:35
5

There are multiple potential solutions to this nuissance, listed in order of complexity:

  1. Restart Steam
  2. Restart your PC
  3. Navigate to your Steam installation folder and delete or rename the file ClientRegistry.blob. That file causes many problems every now and then... While you're at it, you can also try the same with files starting with ssfn - however that may also destroy any family sharing you configured. Either way, you'll have to log in to Steam again
  4. Check the game's cache integrity (slow...)
4

You might want to try:

  1. right click on Torchlight 2 in steam library

  2. go to Local files tab and try 'Verify Integrity Of The Game Cache...'

if that doesn't help then probably you still have some remains of the mods that cause this error and you should remove them.

2
  • 1
    As of December 2016 the location is: library tab, right click the game, properties, local files tab, verify integrity of game cache button. Dec 27 '16 at 14:35
  • Had this issue with Fallot: New Vegas after moving the game between different partitions a couple of times and the verification found 2 files that were wrong and it works fine now :) Mar 11 at 19:53
1

I ended up re-installing steam itself. After that the problem disappeared.

1

This happened the other day to me as well. I renamed the userdata to userdata.old and restarted Steam. After launching Portal 2 (because this was the game that didn't wanted to sync) again, the prompt didn't show and I was able to play normally. No need to reinstall Steam this way.

1

Running steam as admin worked for me! If you don't want to do that manually every time, you can right click the executable and there's an option to always run as admin in the compatibility tab.

1
  • Did the trick for me as well, whereas no other steps described above helped Feb 13 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.