1

I am trying to make a Gmod server, and believe I have everything set up correctly. I am using SteamCMD. I port forwarded all TDP/UDP between 27000 and 27050. I also port forwarded these ports in my firewall.

However, my server doesn't show up on the list after I start it, and when I type "connect xx.xx.xxx.xxx" it says "Connection failed after 4 retries."

How would one fix this?

  • Does everyone have the issue connecting to the server or just you? – 3ventic Aug 16 '13 at 18:40
  • @3ventic Everyone, I assume. Typing "connect xx.xx.xx.xx" into console doesn't work for either me nor my friend, and the server does not show up on the server list. – avestar101 Aug 18 '13 at 13:34
2

Are you running the server on a local machine at your place? In that case, try using internal LAN address to connect to it. If that still fails, the issue is with your computer's firewall, possibly. Try disabling it momentarily and connect to the server again. If that also fails, then the problem is most likely with SteamCMD. Check that you haven't accidentally changed the ports it's supposed to use.

If your server is on a computer with Gmod installed, try connecting to 127.0.0.1. This is the notorious loopback address, and makes the computer connect to itself. If that fails, then the problem is with SteamCMD. Like mentioned above, check that you haven't accidentally changed the ports it's supposed to use.

If all else fails, try using the HLDSUpdateTool instead. Although aging, and about to be phased out, it is still a viable alternative.

  • This does not work :( – avestar101 Aug 15 '13 at 23:11
0

Is this a server running on your machine or server on another machine in the same network or another machine in the net?

If it is YOUR machine then I'd be just as lost.

If it is another machine, are you both on the same subnet? Are you both in the same workgroup/homegroup(Windows)?

If you're using Ubuntu and its a local only server run ufw disable to take down your firewall.

If it is in the internet make sure you can ping it, also do this if you're on the same network.

If it is a local machine, use this to connect: connect 127.0.0.1:27015

  • It is on my machine. – avestar101 Aug 16 '13 at 2:35
0

steam --> settings --> downloads and cloud --> and change seed of your connection. and restart steam. bug fixed! this will fix you're connection speed bug:you're internet connection changes every second(sometimes low sometimes high). sometimes steam can't fix youre internet connection speed so you must do that.

  • 1
    Why does this fix the issue? Please add that to your answer. – Frank Aug 16 '13 at 13:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.