7

I just installed TF2 and launched it. A steam pop-up said the app already was running.
That weird because I haven't played it on that computer. There is no task called team fortress 2, and the game doesn't seem to be running.

  • 2
    Erm... open task manager, go to processes and close everything that is related to steam and team fortress and try it again. After that, try a restart. – 5pike Jun 25 '13 at 10:29
  • already tried all of that... – RustyMembers Jun 25 '13 at 10:30
  • The same problem happens after a restart? Do other games have a similar problem? – kotekzot Jun 25 '13 at 11:42
  • same after restart, other games dosn't do it – RustyMembers Jun 25 '13 at 11:46
  • 2
    FYI, the executable for TF2 is HL2.EXE, try looking for that in the task manager's "Processes" tab. – Dan C Jun 25 '13 at 15:44
2

Try using the "verify integrity of game cache" feature in Steam. Should be able to find that if you right click your game, go to properties, and look under all of the tabs (if I remember right the last tab). If it still does not work try deleting the local content and re-downloading the game. P.S. Sometimes the simple solution is the best solution. Hopefully that works :D

1

All source-based games run off their "parent", Half-Life 2. As such, their process name in the Task Manager is hl2.exe.

  1. Open the Task Manager, which can be done by right-clicking the Taskbar or pressing ctrl+alt+delete. Both locations have options to open the Task Manager.

  2. Locate the process hl2.exe. It should be pretty easy to locate since it's going to be most likely the top resource-hogging process, or you can sort processes alphabetically. Once found, click on it and click End Task.

  3. You should now be able to successfully launch Team Fortress 2. If not, it would be a good idea to reboot your computer.

  • i have tried it and it doesn't neither does rebooting. – RustyMembers Jun 27 '13 at 11:28
0

If you can't find HL2.exe, gameoverlayui can also cause this error.

-1

What you need to do is it will do that it happens to me when I install games you just have to restart your steam. Thats what I do and it works after I log in.

-2

I had this problem before: I couldn't launch TF2. However, after I updated it worked.

I think the safest way is to wait for an update.

  • Read, and you've just repeated what he said. (Yes, click the links or scroll up) – aytimothy Aug 27 '15 at 7:29
-2

Restart your computer in order to close any processes that may not have closed properly and are interfering with the game or steam.

  • 1
    Why will this help? As generic info, it could be useful, but as it currently stands, it really isn't. – Frank Oct 23 '15 at 0:01

protected by Studoku Oct 22 '15 at 23:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.