I recently bought The Guild 2 from Steam. The game seems to function fine, but during the intro all I get is a black screen with the sound of the intro movies. Pressing Esc does get me to the Main Menu.

My system specs:

  • Windows 7 64 bit.
  • Core 2 Quad.
  • NVIDIA GeForce 8800 GTS

How can I fix this issue?

4 Answers 4


Have you tried to change your Config.ini file? Specifically the line "Splashscreen=1" to "Splashscreen=0"

This fixed 99% of folks having the problem


I got that problem with some other games, after installing the latest Windows Media Encoder 9 Series (in your case for Win7, 64bit) all videos just worked fine afterwards.

So just take a look here and get the latest encoder:

Windows Media Encoder 9-Series

Hope that works for you too.


As implied by Iceag, Steam games use a media viewer based on the OS player. If the media player is not up to date, no video for you.

If it's not enough to fix it, i recommend you to verify the fragmentation of game files (through the property menu). It'll solve fragmentations problems, and check for damaged files, so it may fix your problem too.

If these actions don't fix your issue, and you don't mind not seeing the intro, you should put -novideo in the launch options (through the property menu). It will result in not displaying the video, and directly load the game.

If you really want to see the intro, and none of the two first solutions worked, you can still try to uninstall/reinstall the game.


Not an answer to your question, but if you'd only like to watch the intro once, head over to Youtube, e.g.

  • Oh, it even gets embedded. So, do not head over to Youtube and just watch it here!
    – mafu
    Commented Oct 20, 2013 at 10:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .