I can not deal damage to ghosts in Skyrim. Arrows are flying right through them. Spells too. Does anyone know if this is some kind of effect from SkyRe or any other mod?

I have unofficial patches, SkyRe, Apocalypse, Frostfall, Alternate Start and a bunch of visual mods installed.

I tried turning off all the mods in the nexus mod manager except for Update, Dawnguard, HearthFires and Dragonborn. Still can't deal damage to ghosts.

Also I've found a workaround: Apocalypse has two spells: phantom image and feint warfare. First one creates a dummy that is supposed to distract everyone. Second one makes this dummy cast a fake destruction spell. Turns out that fake destruction spell does damage to ghosts.

The question here is how can I troubleshoot it, what might be the cause and how to fix it.

  • Disable the mods and see?
    – kotekzot
    Commented Jun 30, 2013 at 15:35
  • Tried that, no change.
    – clorz
    Commented Jun 30, 2013 at 15:43
  • @clorz: If disabling the mods doesn't fix it, then it's not their fault. :P Commented Jun 30, 2013 at 17:27
  • 1
    Sadly, due to the way skyrim works, you cannot simply disable mods. It saves a lot of the scripts in your save file. So, disable mods, restart the game with a new save, find a ghost and try again.
    – Ids
    Commented Jul 1, 2013 at 8:26
  • Read the Skyre documentation, it says: "Ghosts: Ethereal (as in "Become Ethereal") when not attacking" so that is the answer to your question right there.
    – Ids
    Commented Jul 1, 2013 at 8:34

1 Answer 1


This is caused by SkyRe, it makes the ghosts invulnerable when you are not attacking them. That the fake destruction spell can damage them sounds like a bug to me. Might want to mention it to the creator of skyre.

You can read more about the changes Skyre makes in the skyre guide. Ignore the silly description of the mod, the guide is actually pretty clear in what skyre changes.

Have you tried turning it off and on again?

One important note on disabling mods in skyrim. Skyrim is not oblivion or fallout. Mods are hard to disable on a running game. Any scripts that a mod includes and attaches to objects is saved inside the savefile. So in a lot of cases disabling the mods has little effect. (At least not until the objects respawn).

It is very easy to bloat and eventually wreck your savefile by installing and then disabling mods. When using new major mods, always use a clean safe, or, a clean game start.

There are a few 'tricks' you can use to more safely disable mods. First, if you are using SKSE, you can create a SKSE.ini file in the "my documents/skyrim/SKSE/" directory. (location of this dir may vary, it is the same one as the skyrim.ini dir). Add the following line to the ini file:


This should remove invalid scripts.

And always follow this guide when installing new mods.

  • Just checked that with slow time potion. Ghosts are indeed only invulnerable until they start attacking me. Thanks for the guide =)
    – clorz
    Commented Jul 1, 2013 at 19:33
  • I actually had to follow the guide myself. And my game is getting rather unstable. Fubar...
    – Ids
    Commented Jul 2, 2013 at 8:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .