1

I have been playing CS 1.6 in a particular server for a long time. The problem started just from today evening. Suddenly I observed everytime I connect to that particular servers address, I am redirected to some random server where the redirected server may be full or empty. The server is enlisted in Gametracker (ip: 84.200.5.189:27015). I can also see people are playing there, but sadly I cant join now. Please help me to fix this problem. I have uninstalled and reinstalled the game. No luck.

EDIT- The console after connection looks like:

]connect 84.200.5.189:27015 NET Ports: server 27015, client 27005 Server IP address 116.203.182.90:27015 Connecting to 84.200.5.189:27015... Connection accepted by 84.200.5.189:27015 Unable to open resource/gamemenu.res [AMXX] Simple Redirection - Redirecting to 46.17.98.104:27019 * Privileges set

Connecting to 46.17.98.104:27019...

You are using HLServer 1.16 by [RTsK] RATWAYER Technical support - ICQ 289012

Have Fun =)

Redirecting connection to 93.119.24.96:27015;bind "h" "Connect 93.119.24.96:27015";bind "v" "Connect 93.119.24.96:27015";bind "x" "Connect 93.119.24.96:27015";bind "z" "Connect 93.119.24.96:27015";bind "c" "Connect 93.119.24.96:27015";bind "ALT" "Connect 93.119.24.96:27015";bind "F3" "Connect 93.119.24.96:27015";bind "F4" "Connect 93.119.24.96:27015";bind "F5" "Connect 93.119.24.96:27015";bind "F6" "Connect 93.119.24.96:27015";bind bind "F6" "Connect 93.119.24.96:27015";bind "F7" "Connect 93.119.24.96:27015";bind "F8" "Connect 93.119.24.96:27015";bind "F9" "Connect 93.119.24.96:27015";bind "F10" "Connect 93.119.24.96:27015";bind "F11" "Connect 93.119.24.96:27015";bind "F12" "Connect 93.119.24.96:27015";bind "INS" "Connect 93.119.24.96:27015";bind "DEL" "Connect 93.119.24.96:27015";bind "PGDN" "Connect 93.119.24.96:27015";bind "PGUP" "Connect 93.119.24.96:27015";bind "HOME" "Connect 93.119.24.96:27015";bind "END" "Connect 93.119.24.96:27015". Connecting to 93.119.24.96:27015... Connection accepted by 93.119.24.96:27015 Can't unbind ESCAPE key * Privileges set

My config file is totally clean and it is "read-only". So how can I solve this problem? Thank you.

5
  • 1
    Is the server full? Sometimes a group of servers are setup such that when you cannot join the primary server you are redirected to a secondary server. If there are only two open slots those slots are probably there so people join the server and get redirected instead of getting the "server full" message. – Sadly Not Jul 5 '13 at 16:55
  • May be a messed up config file: delete your config.cfg file. forums.steampowered.com/forums/showthread.php?t=1865696 – Colin D Jul 5 '13 at 16:57
  • @SadlyNot, That is not the case. I can chat in facebook with my co players there and they confirm me server is not full, rather less than half players are playing that time. – Mistu4u Jul 6 '13 at 14:05
  • @Mistu4u If that's the case I can't say from experience what's happening :( best of luck figuring it out. – Sadly Not Jul 17 '13 at 22:24
  • This happened with me too. Turns out server changes these bindings when we connect to it. It's best to setup your configuration and make it read only - CS 1.6 redirection to other server issue – Aniket Thakur Mar 29 '17 at 8:22
2

This happens when some rogue server edits your config.cfg file and adds command to auto-redirect.

To stop this:

  • Delete your config.cfg located in your /cstrike folder:
    • Location for STEAM: C:/ProgramFiles/Steam/Steamapps/common/HalfLife/cstrike/
    • Location for Non STEAM: C:/ProgramFiles/Valve/Counter-strike/cstrike/
  • Start your CS and your new config.cfg will be auto written or type "writecfg" in console to make that file..

To avoid this in future --> in /cstrike folder make config.cfg as read only:

  • (Right click the file -> Properties -> Tick 'Read Only')

and enjoy gaming... :)

1
  • 1
    For mac steam path is /Users/username/Library/Application Support/Steam/steamapps/common/Half-Life/cstrike. – Aniket Thakur Mar 28 '17 at 19:22
0

At first I, along with other co players of the same server, thought that we were being slow-hacked by the server. But later the admin himself informed us in Facebook that even he was facing the same problem. I don't know some kind of upgradation was then carried out in the server side and later everything returned to normalcy again. So it was not a problem in the client side, rather a server side problem and clients could do nothing about it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.