10

I have a very old PS2. It worked fine for the longest time, but recently I have a strange problem. Every time I turn it on, no matter which game I use, it acts as if I am holding the analog (or possibly d-pad) left.

As a result, the only thing that works is pressing Start. When I manage to load a game (by just pressing Start repeatedly) the character spins around ceaselessly. The only other control that works is the other analog stick.

This means that in Tony Hawk games, for example, I am constantly spinning in a circle. Using the other analog stick I can observe myself spinning from above, below, or any angle in between, but I can neither stop turning nor change direction using the other stick or d-pad, and as I said, no other controls work.

I have tried turning the machine on with the controller in slot 1, in slot 2, and not plugged in at all. Nothing changes. I followed the instructions here:

How to fix broken controllers/pads?

... although the fact that this is happening even when no controller is plugged in makes me think it is not a controller issue. I am even more sure of this since I went out and purchased a second-hand controller today, and the situation has not changed.

Any ideas?

EDIT:

Borrowed another controller, a non-Sony one this time. No difference. Also took the PS2 apart and cleaned it as best I could, tried inspecting for damage but as before found nothing obvious amiss.

Is it possible this is a software problem? Corrupted OS, maybe...?

EDIT 2:

In desperation to get a Tony Hawk fix, I tried PCSX2 (the PS2 emulator for PC). While in the process of hooking up my controllers to the PC, though, I ran a test and discovered something curious:

One controller is sending constant buttonpress signals for all buttons all the time. The other controller is sending a constant signal for just one buttong (d-pad left), again all the time. Taking them apart and cleaning the contacts had no effect.

I think I need to consider the possibility that both of my controllers and the one I borrowed for testing were all, unlikely though it is, malfunctioning. The system is certainly acting as though a button is being pressed all the time. The fact that it acts the same even with no controller is hard to explain away, though. Just wish I had another PS2 to check with.

Graarrgh!

  • I would try to answer, but I really know nothing about hardware, so this is what I think. Maybe some kind of pin in the controller slot is pushed in a weird way or something? – trainer-blue Jul 8 '13 at 15:06
  • Yeah, I thought about something along those lines, so I cleaned the pins as best I could with compressed air... no effect. I also looked briefly at the internals, thinking maybe there was a loose or crossed wire, but it looked intact and not corroded. I don't know much about how the signal is transmitted, so it's hard to know what to look for. And then there's the possibility that it is a software bug, and all of this is irrelevant :-/ – David John Welsh Jul 8 '13 at 15:20
  • Can you use the controller to move the joystick to a position that your PS2 'thinks' is centered? Maybe get it there. Turn the system off with it there. Then turn it back on with it actually centered? I'm not hardware either but it's something that I would try (whether it would actually work or not I have no idea) – Reafexus Jul 17 '13 at 13:05
3

I ordered a brand new controller from a third-party developer, plugged it in, and it worked fine. Strangest thing is that now the old controllers work too, but only as long as the new one is in the socket when I turn the machine on. As long as the new one is there on startup, I can switch them out and they work fine. But the problem persists as before if I don't do this.

In conclusion, I have no idea why this problem happened, but I did manage to "fix" it. If anyone else has a similar problem, I recommend buying a brand new controller, I guess.

1

When my ps2 controller started pressing buttons I was not pressing I took it apart & put a piece of electrical tape to hold the thin plastic piece (looks like clear scotch tape w/gold thin wires built inside of it) onto the circuit board. The under side of the ps2 controller (on the inside of the controller) has what looks like a piece of dark gray foam built into it that holds the thin plastic piece (looks like clear scotch tape w/gold wires built inside of it) onto the circuit board. The electrical tape I put there assists the dark gray foam piece in having to do it's 'job'. After doing this my ps2 controller worked like new again.

-1

Ive had this problem several times but my fix was very simple. All I ended up doing was removing the controller from the port and putting it back in check your ports on your controller maybe a end is damaged. Also check if the port on the ps2 is broken.

  • If the ends are damaged I do not know how to fix. – zeke Aug 16 '13 at 14:03
  • Reading the question, the OP has already attempted this without success - "I have tried turning the machine on with the controller in slot 1, in slot 2, and not plugged in at all. Nothing changes" – Rory Aug 16 '13 at 14:44
  • @Rory but have they checked the ports – zeke Aug 22 '13 at 17:37
-2

Your PS2 is broken on the inside and could probably only be fixed if you sent it to Sony, you could try letting it sit there and see if it will stop after a while.

  • 2
    Hey, Wade, welcome to Arqade. How do you know his PS2 is broken? What information do you have that leads you to believe this is true? – Frank Aug 25 '13 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.