14

My friend and I are trying to solve an issue we're having with Steam. My friend cannot connect to any Steamworks servers (such as Garry's mod/TF2 servers).

We have tried:

  • Deleting ClientRegistry.blob,
  • Exiting programs that interfere with steam,
  • Adding rules to Firewall

We have posted a ticket on Steam support - they told us to delete everything in the installation directory (/Program Files(x86)/Steam/) except steam.exe and steamapps, but that didn't work either. It made our situation worse, as now my friend cannot even connect to Steam (with an error "Could not Connect to Steam Network")

We're all out of ideas, has anyone else come across a similar issue?

  • How recently did this issue start? There was an accidental patch today that Valve has reverted, so that could be the cause of issues that only recently began. – Sadly Not Jul 16 '13 at 23:43
  • It happened ever since he got steam which was about a year ago. But the steam network error happened when he deleted all the files in /steam/ except steam.exe and steamapps. – Wizdo Jul 16 '13 at 23:52
  • 3
    @Wizdo - For reference, "Delete everything except steamapps and steam.exe" is Valve's stock standard response. (Kind of like "have you tried turning it off and on again?"). Every issue I've posted to Steam Support has gotten this exact response. I'd reply back and say these steps didn't work, and now you can't connect at all. That seems to get an actual response from a person – Robotnik Jul 17 '13 at 0:10
  • @Robotnik - I did say it didn't work and he couldn't connect anymore and they replied "sorry we can't help you any more, but you could go to this post for support support.steampowered.com/kb_article.php?ref=1456-EUDN-2493 " – Wizdo Jul 17 '13 at 0:39
  • 4
    Try whether your machine can connect to Steam: firebind.com/tests/steam (needs Java browser plugin) – Chris Jul 19 '13 at 7:22
3
+25

It looks like similar users share your frustration for this annoyingly horrible issue:

However, it seems there are several fixes for this that have worked for other users:

Solution A:

Rolo: for me, this problem was caused by a optional windows update, ralink wlan 802.11n usb wireless lan card. I fixed it by going to device manager, network adapters, driver, roll back drivers. hope this helps someone.

Solution B (similar to A, for Win7):

Seismoid: I had the same problem with my steam client ("Could not connect to steam network", then after deleting everything but steam.exe and /steamapps folder "steam client has to be online to update", then after uninstalling steam and trying to reinstall it took ~20 tries until it downloaded the 110mb without error, but still kept getting errors that it could not connect to steam network). In my case I just took a look at the windows update history (win7) and found out that the wlan driver was updated on march 5th. So I rolled back that update and everything worked again. You might want to give it a try if you have similar issues with your steam client as those mentioned in this thread.

(I use Windows 7) First you should check if there is an update of your wireless driver in the update history.

  1. Go to Control Panel -> System and Security -> Windows Update
  2. On the left side click "View update history"
  3. Look for a line that says "Ralink - WLAN - ..." (in my case it was "Ralink - WLAN - D-Link DWA-140 RAngeBooster N USB Adapter", my wlan stick); hint: you just have to check the last 2-3 weeks - or whenever your steam client stopped working - so sort the updates by a click on "Date Installed" at the top ;)
  4. If there was an update and you want to try to roll back:
  5. go to Control Panel -> System and Security -> System
  6. click on "Device Manager" on the left side
  7. expand the "Network adapters" node in the device tree
  8. right-click on your wireless adapter mentioned earlier (here it only says "D-Link DWA-140 ..." - no "Ralink - WLAN -" as prefix)
  9. choose "Properties" in the context menu
  10. go to the "Driver" tab and click "Roll Back Driver"
  11. wait until windows is done rolling back (you may need to restart; though I didn't have to)
  12. dont install those drivers again if steam client works now :) (might need to deactivate automatic windows updates)

It seems in most of the cases, Steam's problem stems from a bad Wi-fi or network driver. It also doesn't hurt to check your antivirus or any firewalls running. See if disabling all anti-virus software while running Steam should work. Some users have found that their AVs were in fact blocking Steam.

9

Deleting the appcache folder in my Steam folder did the trick for me.

  • Deleting the appcache folder also worked for me :) – user54177 Aug 23 '13 at 15:27
  • beware, my folder had 40.000+ files (wtf httpcache) This takes awhile without SSD. – Timmetje Dec 6 '13 at 19:44
  • This did not work for me – Wandang Aug 10 '14 at 21:21
  • this just worked for me, granted after a windows update but not connecting over wlan – DarkMukke Nov 22 '14 at 12:12
  • 1
    Didn't work for me. – AaronMaroja Jun 17 '15 at 14:10
0

Another answer - just in case above did not work:
Steam error: Could not connect to a network on Windows 10

  1. Close Steam (by right clicking and selecting Exit).
  2. Create a shortcut to Steam.exe
  3. Right-click on shortcut and select Properties.
  4. Alter its starting location by adding -tcp at the of path - it should look like:
    "C:\Program Files (x86)\Steam\Steam.exe" -tcp
    (quotes intended)
  5. Start Steam using said link. It will fail to connect to Steam network.
  6. Press retry option. After a few seconds you'll be logged in normally.

Doing that will me Steam use TCP protocol instead of UDP. TCP ensures successful data packet delivery but is slower (which is most likely why it's not used by default).
Even if this solution helps, you should first try starting Steam normally and prefer using it without TCP if it loads (which is why I suggest making shortcut and not changing startup parameters on actual file).
Hope it helps - cheers!

Not the answer you're looking for? Browse other questions tagged or ask your own question.