In the SNES game Secret of Mana, all the weapons seem to have 8 orbs, and thus 9 variations, except the Mana Sword. It doesn't seem possible to forge the Mana Sword more than 7 times, to get it to level 9. Is there a way to forge the 8th level sword, the Dragon Buster? And if so, what is the 9th sword?

3 Answers 3


In the standard gameplay, there is no 9th orb for the sword. I've placed the reason for this in the following spoiler block.

The final sword is the Mana Sword. You can only get it by casting the spell Mana Magic, which you get just before the final battle. It upgrades your sword to that level for the duration of the spell.

There is, however, a glitch that can let you use it normally. You can find this information in this other answer. ♪


The 9th version of the Sword is the Mana Sword. The only way to get this during "normal" gameplay is via Dryad's final spell, "Mana Magic". When both the Girl and the Sprite cast "Mana Magic" on the Boy, the Dragon Buster becomes the Mana Sword.

There is, however, a way built in to the game to forge the Dragon Buster one final time to obtain the Mana Sword before you get Dryad's magic:

  1. Back up your save game, in case you make a mistake…

  2. Using Flammie, fly to the Ice Country and find the small island near the Ice Palace. Land directly on this island.

    Screencap of island to land on

  3. If you found the correct island, you'll land right in front of Neko. Save your game.

  4. Perform an in-game reset by holding down LRSelectStart. You have now placed this save game file in a special state, where next time you load it, the characters will start from wherever the previous characters were. So if you play a different save game file, and perform an in-game reset, and load the save file saved at Neko, your characters who saved at Neko will now be where the other characters were. So to exploit this…

  5. Start a new game. Play through until you reach the Mantis Ant. Many people claim you should kill as few Rabbites as possible; this is a myth.

  6. When you reach the Mantis Ant, and Jema is telling you how to kill the Mantis Ant, perform another in game reset (LRSelectStart). Be sure to hold the buttons for at least 5 seconds; My theory is because the game is saving to SRAM the location of your character (at the Mantis Ant).

  7. Load the save game file where you saved at Neko. Instead of being at Neko, you'll be fighting the Mantis Ant. When you defeat him, you again get a sword orb! Forge your sword one final time to obtain the Mana Sword, the most powerful weapon in the game.

This process can be repeated to teleport your characters to any part of the game, not just the Mantis Ant. However, most locations will not still have the bosses, only the Mantis Ant seems to reappear and give you an Orb. Also, while you can repeat the process to obtain more than 9 orbs, if you forge the Sword past level 9, the game will get "confused" and the sword will change to a different weapon, like the Gloves.

  • Note, for anyone wondering, this glitch won't work on the iPhone version of Secret of Mana. You can hex edit the save file if you jailbreak your iPhone, though.
    – Andy E
    Jan 25, 2011 at 21:32
  • @Andy: It won't? That's too bad. Do you know if it works on the Wii version? I have heard it only works on the NTSC version, not the PAL versions.
    – Josh
    Jan 25, 2011 at 21:35
  • @Josh: not sure. I have the PAL version on the Wii but I haven't tried it. The reason it doesn't work on the iPhone is because there's no button-mapped soft-reset - you have to enter the settings to perform the reset. I just did a little reverse engineering and found the byte locations for sword orbs in the save file, though, so it's all good :-) I have a theory about the hex editing the current location, too.
    – Andy E
    Jan 25, 2011 at 21:39
  • Theory panned out... so "teleporting" is possible too.
    – Andy E
    Jan 25, 2011 at 21:45
  • Awesome @Andy! Post that as an answer and I will upvote!
    – Josh
    Jan 25, 2011 at 21:53

I added, as a comment, to Josh's answer that the glitch won't work on the iPhone version of the game. In fact, the island is different (it's a different shape) and you can no longer land on it:

Island is a different shape! And you can't land on it!

If you're brave enough to jailbreak your iPhone you can hex edit the save file to change one tiny byte to give you 9 Sword Orbs so that Watts will reforge it into the Mana Sword.

To do this, you will need:

  • A jailbroken iPhone (obviously), with a method to browse the private files (hint: search Cydia for afc2add).
  • A hex editor. My personal choice is HxD because it has a portable version.
  • An app for exploring your iPhone's files. I used i-FunBox (Win only), but I don't like how many ads they stick on their site so I refuse to link to it.


  1. Connect your iPhone to your computer, open your file browsing app and navigate to the applications directory (//var/mobile/Applications/ or User Applications in i-Funbox).

  2. Locate the Secret of Mana app folder. This will be the app's unique ID, the folder contains the app name, which is sk2.app.

  3. Inside that folder, locate and open the Documents folder. This folder contains the save files to copy to your computer, labelled sk2_0sav, sk2_1sav and sk2_2sav for each save slot.

  4. After copying to your computer and making a backup of your chosen save file, open it in your hex editor.

  5. Navigate to hex offset 0587 (in most hex editors you can hit Ctrl+G, then type in 0587 to go straight to that byte) and replace the byte value with 09, as in 9 sword orbs.

  6. Save the file and copy back to your iPhone. Et Viola. You can now visit Watts and fork over 25,000 nuggets to upgrade the sword to level 9.

Take great care whilst editing the hex file. Any values must be overwritten, never inserted. Changing the offsets of other values will corrupt the file. It's best to make sure the file size never changes.

  • 1
    AWESOME! Thanks for sharing this, +1!
    – Josh
    Jan 25, 2011 at 22:52
  • 1
    @Josh: lol I believe it's a glitch. There's two different hex offsets in the save file that describe the current location, interestingly enough. I'm speculating that one of these offsets wasn't written properly when saving in the SNES version and soft-resetting didn't clear this value either. So for certain locations in the game, the saved value of one offset mixed with the in-memory value of the other offset teleports you. In the iPhone version, they appear to have fixed either the incorrect saving or clearing the value on reset. I've tried everything I can think of and it can't be done ;-)
    – Andy E
    Oct 5, 2011 at 8:08
  • 1
    Hmmm.... that's interesting to know! But since it only happens on one little island, doesn't that seem like it might have been deliberately programmed in? And how was this glitch ever found I have always wondered. It's so obscure I believe a programmer intentionally set one of those offers to a "magic" value. It persists across poweroffs on the SNES version, too, I've tested that. However I reluctantly take your word that it's been "fixed" in the iPhone version, even if I believe that it's been "broken" LOL
    – Josh
    Oct 5, 2011 at 12:43
  • 1
    @Josh: maybe you'd find this old GF thread interesting :-)
    – Andy E
    Oct 5, 2011 at 12:55
  • 1
    Thanks Andy! It's posts on forums like that which drive me crazy and fascinate me at the same time. I love SOM and want all the information about it I can find, but I believe 98% of what's in forum posts like that is all B.S... Like this: "My friend, playing as the sprite, tried to attack an imp but instead began shaking it like a chest. It said that we got a sword orb, but it froze right after that" -- I have never had that happen to me in 18 years of playing this game! (StackExchange FTW BTW) -- But than you, this thread is fascinating!
    – Josh
    Oct 5, 2011 at 13:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .