5

I was able to install Rogue Legacy 1.1.12c on Ubuntu 13.04 with Wine 1.4.1, but running it fails:

$ wine ~/.wine/drive_c/Program\ Files/Rogue\ Legacy/RogueLegacy.exe
wine: Install Mono 2.8 or greater for Windows to run .NET 4.0 applications.

I managed to install Mono and .NET:

  1. Removed Wine installation:

    $ rm -rf ~/.wine
    
  2. Downloaded gacutil-net40.tar.bz2 and prepared it for installing .NET 4.0:

    $ mkdir -p ~/.cache/winetricks/dotnet40
    $ mv ~/Downloads/gacutil-net40.tar.bz2 ~/.cache/winetricks/dotnet40
    
  3. Installed .NET 4.0:

    $ winetricks dotnet40
    
  4. Figured out which Mono version I could install with Wine:

    $ winetricks dlls list | grep -o '^mono[0-9]*'
    mono210
    
  5. Installed the Mono version I found above:

    $ winetricks mono210
    

Now I get the following result:

$ wine ~/.wine/drive_c/Program\ Files\ \(x86\)/Rogue\ Legacy/RogueLegacy.exe 

Unhandled Exception: System.TypeLoadException: Could not load type 'RogueCastle.Game' from assembly 'RogueLegacy, Version=1.0.12.0, Culture=neutral, PublicKeyToken=null'.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type 'RogueCastle.Game' from assembly 'RogueLegacy, Version=1.0.12.0, Culture=neutral, PublicKeyToken=null'.

PS: Yes, I'm too impatient to wait for the Linux port. This game looks too awesome!

  • 2
    From that error, it sounds like you'll need to wait for the Linux port. – Frank Jul 19 '13 at 20:46
  • 2
    "your version of mono is too old as indicated here terrariaonline.com/threads/… " - hbdgaf # – badp Jul 19 '13 at 21:19
  • i might add that "mono" in the context of wine means the version of C#, so your winetrick is too old. – RobotHumans Jul 19 '13 at 21:39
  • 1
    The Linux build of Rogue Legacy has since been released. – user98085 Dec 18 '13 at 0:01
3

Please follow the guide provided in AskUbuntu to Correctly Configure and Install Wine which I made for cases like this.

After doing so then you can see in the Wine AppDB for Rogue Legacy the components needed for it which I also worked on. There is no additional steps apart from using the correct updated/configured Wine version and installing the needed components which, as you mentioned are the .NET Framework and/or Mono 2.10.

After running winetricks (The gui window) should show you that you have mono installed (And any other additional components. You can see which you need in the askubuntu answer I provided).

Additionally, and aside from the above mentioned, when running a Windows executable app with Wine, you should know 3 things:

  1. Some apps DO NOT execute if the executable file is not in the same folder where you are actually executing wine. For example:

    wine ~/.wine/drive_c/Program\ Files\ \(x86\)/Rogue\ Legacy/RogueLegacy.exe 
    

    Will NOT WORK but

    cd ~/.wine/drive_c/Program\ Files\ \(x86\)/Rogue\ Legacy
    wine RogueLegacy.exe 
    

    WILL WORK.

  2. When adding the location of a Windows executable and it contains names with spaces in them, it is always better to double quote the location than it is to simply assume it will work. For example the above can work better like this:

    wine ~/.wine/drive_c/"Program Files (x86)/Rogue Legacy"/RogueLegacy.exe
    
  3. Some games do not play well on a 64 bit environment. Since I see you have "Program Files (x86) with you, this just means you have Ubuntu 64 bit and simply installed Wine which by default takes the ARCH type of the Host system, in your case 64 bit. Please see the guide for Wine which talks about this.

So with this 3 points in mind and the guides, you should have a nice play of, not only this game but many MANY others.

  • If the path is correct it does not matter whether it is written with backslashes or quotes (point 2) - the exact same string will be passed from the shell to wine, so there's no difference. Of course, if a special character is not escaped or quoted properly, it won't work in either case. – l0b0 Aug 4 '13 at 20:16
  • I added that part to make it simple for new users. It is far easier to read a quoted multi word folder/file than reading one with many slashes. – CYREX Aug 5 '13 at 2:09
2

Specific solution based on @CYREX's generic answer:

  1. Remove all Wine-related applications and ~/.wine
  2. Install Wine 1.6 or newer
  3. Install the dependencies with

    export WINEARCH=win32
    winetricks xna40
    

    During this I got a bunch of err and fixme messages, including the following:

    xna40 does not install properly in wine yet
    dotnet40 does not yet fully work or install on wine.  Caveat emptor.
    

    However, the exit code is 0, so I guess it worked. Installing the game worked fine:

    wine ~/download/games/RogueLegacyv1.0.10a.exe
    wine ~/download/games/RogueLegacyPatchv1.0.12c.exe
    
  4. It works!

    cd ~/.wine/drive_c/Program\ Files/Rogue\ Legacy/
    wine RogueLegacy.exe
    
  • did you get it from here? – Wilf Aug 1 '14 at 15:38
  • @Wilf Yes, why? – l0b0 Aug 1 '14 at 17:42
  • I had problems getting it to work with Wine 1.6 and 1.7 (newer version issue probably)... never mind :) – Wilf Aug 1 '14 at 17:43
2

There is now an official Linux port available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.