I'm trying to do the Boethiah's Calling quest and I need a follower for it of course to sacrifice. But whenever I ask someone to be my follower they say I already have one. This is a problem because I don't have a follower. I had a dark brotherhood follower a month or two ago but I lost her and haven't been able to find her since. I've fast traveled and slept and tried multiple things to find her but to no avail. Now I can't get a new follower for the quest or get rid of my old one.

  • Hey, @cooiejr. Don't challenge a duplicate in your question body. Either comment on it, and flag for re-opening, or ask on Meta. Either way, "Does not help me" is not a valid reason to re-ask a question. Have you followed the directions in the duplicate question?
    – Frank
    Jul 25, 2013 at 16:52
  • Yes all of the answers dont apply to my specific problem. For example one of linked problems the answer was they were on a companions quest which caused it to count as a follower. So all they needed to do was that quest. An answer like that doesnt help me in anyway as I finished that quest a long time ago. My question sure might be a duplicate but the solution to my problem isnt found on any of those.
    – Cooiejr
    Jul 25, 2013 at 16:57
  • @Cooiejr Have you fast-traveled in a mission, as explained here? gaming.stackexchange.com/a/79584/1721. If that doesn't help you this may be worth re-opening for an answer.
    – Sadly Not
    Jul 25, 2013 at 17:52
  • Ive tried all of those which makes me think that my game is just glitched with no solution because for 1 the dark brotherhood initiates cant die. 2 if they did I could recruit a new follower and 3 its been allot longer than 3 days since ive seen them and there not at the sanctuary.
    – Cooiejr
    Jul 26, 2013 at 0:23

1 Answer 1


Chances are, the follower went back home. You mentioned a female Dark Brotherhood member, which sounds like a Dark Brotherhood Initiate. You can probably find them in the Dawnstar Sanctuary. If they're not there, wait three Skyrim days and try again.

  • Ive checked the sanctuary mulitple times and despite waitng and sleeping more than 3 days I cant find her anywhere.
    – Cooiejr
    Jul 25, 2013 at 2:15
  • @Cooiejr Have you tried hiring a new Initiate? it could be they've bugged out.
    – ian5v
    Jul 25, 2013 at 2:17
  • Yeah Ive tried that and they still say I have someone with me.
    – Cooiejr
    Jul 25, 2013 at 16:34
  • The other answer says you might've started a companions quest that makes Farkas your follower. Check Dustman's Cairn.
    – ian5v
    Jul 25, 2013 at 20:46
  • Saddly I finished that quest a long time ago so that cant be it :/
    – Cooiejr
    Jul 26, 2013 at 0:19

Not the answer you're looking for? Browse other questions tagged .