The in-game audio is not working at all, no music in the menus, no effects or nothing while playing (Microsoft Live sound does work, though).

This is the environment:

  • Steam client
  • Windows 8 64 bits
  • ASUS P7P55D integrated sound card for audio

The sound card is connected to a receiver through SPDIF. Everything else works without a problem, both in 5.1 (movies) and stereo (music and games). I do not use AC3 or any encoder for 5.1 gaming. All of the other games I have do not have any sound issue. I have also tried to connect headphones to the corresponding jack in the sound card with the same bad result.

  • Have you checked the Windows audio mixer? Right-click the speak icon in your taskbar.
    – ian5v
    Jul 25, 2013 at 21:58
  • 2
    Is just Dark Souls sound not working, or any sound at all?
    – Frank
    Jul 25, 2013 at 22:14
  • I have checked everything and looked for answers here and other places, but I didn't find anything. The audio mixer doesn't show activity coming from the game. I also tried connecting headphones to the headphone output in the sound card.
    – Tasio
    Jul 26, 2013 at 7:50
  • 2
    Voting for a reopen. I don't get what is unclear about the question. I suppose Microsoft Windows Live is working, because it is a different application.
    – DrFish
    Jul 26, 2013 at 13:01
  • Also, check this thread out: forums.steamgames.com/forums/showthread.php?t=2900321
    – DrFish
    Jul 26, 2013 at 13:05

1 Answer 1


I finally found the problem. It seems that I didn't realize, but actually the AC3 encoder was starting alongside the game and not processing the audio properly. I disabled the AC3 encoder to process PCM and now it works, although now AAC audio won't work with my player. At least now I have something.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .