3

I have made a Feed The Beast Ultimate server for a couple of friends. When I try to connect to it, it says connection refused:connect, which, according to this post mans that there is no server online, or my router is not port forwarded properly. However, none of these apply. My router is port-forwarded correctly, and it's not a firewall problem either (I tested by disabling Windows Firewall for a couple minutes and failed to log in). I can connect by using my internal IP and localhost on the same computer. I have not tested if the internal IP works on a different computer on the same network. So, given the above information, what could be the problem? Did I forget something?

Port-Fowarding Setup

  • Generally speaking you shouldn't use your external IP to connect to your own computer as it's just extra networking. Can your friends connect using that external IP? – 3ventic Jul 26 '13 at 16:38
  • @3venticNo, that's the problem. – user28379 Jul 26 '13 at 16:39
  • If your friends can't connect either then you have a problem with the port forwarding setup, or something else is blocking the IP. Check with some port checking tool if the port is properly opened. – 3ventic Jul 26 '13 at 16:44
  • @3ventic see my picture – user28379 Jul 26 '13 at 16:46
  • 1
    If you open up your cmd.exe (Command prompt) and enter ipconfig, what is listed under IPv4 address? THAT is what you should put in Private IP there. – 3ventic Jul 26 '13 at 16:47
9

It looks like you have your public IP typed into the Private IP field on your port forwarding setup. The public IP is assigned to your modem/router by your ISP.

You will want to instead put your private/internal IP in that field. This is the IP assigned to your computer by your router. You can find your internal IP (under Windows) by opening cmd.exe and typing ipconfig. You will look for a line that says:
IPv4 Address.....: 192.168.x.x

Type this whole address into your router's port forwarding configuration as your "Private IP". As Kevin points out in the comments, if the computer you are using as your minecraft server is different from the computer you intend to use to play, this applies to the server computer.

This tells your router that when it is accessed on port 25565, it will forward the information to a specific computer on your network, specifically the one you list in that box. Your friends (outside your network) will still use that public IP to contact you.

  • Do this on the machine that is hosting the server. If you have a computer dedicated for your minecraft server, minecraft traffic should go to that one, not your regular computer. If you installed your server on your regular computer, forget what I said :) – Kevin Jul 26 '13 at 18:13
  • So I would use 192.168.0.101? – user28379 Jul 26 '13 at 18:16
  • 1
    @jeffreylin_ if your minecraft server is hosted on the computer that has that ip, yes. – Kevin Jul 26 '13 at 18:17
  • @jeffreylin_ Note that 192.168.0.101 is usually a DHCP-assigned dynamic IP and can change, especially if you have multiple computers on your network. To host a server, you should investigate giving your computer a static IP instead of using DHCP, so that your port forwarding rule won't suddenly stop working if your server gets a different IP assigned to it some day. – SevenSidedDie Jul 26 '13 at 18:25
  • @SevenSidedDie Very true! You should make your internal IP static so your port forward doesn't suddenly stop working one day. – Timtech Jul 26 '13 at 21:44
1

You could just set the computer that hosts your minecraft server as DMZ. It's really bad practice, because you basically have no safety net for that computer anymore, but it does do the job.

  • 1
    +1 because it works and is probably easier, but I definitely wouldn't recommend it. You can turn DMZ on and off as needed to help mitigate the risks, but setting up port forwarding will be a better idea long term. – PeterL Jul 26 '13 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy