I bought Civ 5 on the Steam sale recently, but it's really hard to play as I'm getting these really bright coloured patches appearing and disappearing on the screen after a bit of playing. Then the menu becomes a mess of random colours after exiting a game. This happened with the graphics set to max and when they were set to the minimum and I have a pretty good computer.

I'm running it on the DirectX10 & 11 mode as recommended and I can run Saints Row 3 in the same mode with no problems. How can I fix this?!

Edit: added some pictures I managed to get

Fairly standard menu... I don't think that there's supposed to be two pictures here This one is rare

  • 13
    Graphics glitches are best described with a screenshot.
    – user98085
    Commented Jul 26, 2013 at 22:57
  • If I can bet ;) check out your graphic drivers or if you play on laptop change your battery settings to max performance I'm pretty sure that this is connected with your issues!
    – iber
    Commented Jul 26, 2013 at 23:17
  • I tried taking a screenshot using FRAPS and print screen, but neither worked. Commented Jul 26, 2013 at 23:29
  • 3
    Can't you just hit F12 from a Steam game and it'll create a screenshot? Or am I misremembering?
    – Adam V
    Commented Jul 29, 2013 at 17:57
  • 7
    That looks like artifacting. Your video card may be going.
    – Frank
    Commented Jul 29, 2013 at 22:03

8 Answers 8


I had almost the exact same problem, and fixed it with the "verify cache" option in steam. That may solve your issue too.

  • Managed to play on the highest settings for a few hours without any problems. It's such a simple solution, but one that no one else thought of. I could believe that my graphics card is going if I had these problems in other games, but I don't. Thank you. Commented Aug 1, 2013 at 4:12
  • If this answer helped you, you can mark it as accepted. Commented Feb 14, 2018 at 13:00

Graphical glitches usually occur because of some hardware issue. Graphics cards get especially hot when working through loads of data, so proper cooling is a must. Therefore what you're experiencing sounds more like a hardware problem than an issue with the game itself. Have you tried running the game on lower resolutions, turning down the fanciness to see if the same thing happens?

  • 1
    It still happens with all of the graphics settings set to the lowest. Commented Jul 27, 2013 at 6:25
  • 5
    Yep, sounds like a dying video card. Commented Jul 27, 2013 at 7:20
  • 1
    @SevenSidedDie I'm not so sure about that. I can run games like Borderlands 2 and Bioshock Infinite on max settings with just having some frame drops. Commented Jul 27, 2013 at 17:41
  • It sounds like an overheating bit of kit to me.
    – shanodin
    Commented Jul 29, 2013 at 22:05
  • Remember that not all games utilize the graphics card in the same way, that is: is less or more intense depending on the engine used in the game and how it is optimized. For instance, I could guess you can run Quake 3 for days?
    – Coreus
    Commented Aug 5, 2013 at 12:57

Try running it on Dx9. That worked for me, even with the settings maxed out.


Try updating your graphics driving to the latest version. Also, does Saints Row 3 use DirectX 10/11? Try running in DirectX 9 mode to see if that resolves the issue.


This is without a doubt a graphical issue, most likely due to a hardware problem in your graphics card. Friends of mine have had similar problems in other games.

Here is what I recommend doing: (if step X does not fix the issue, move to the next step and so on)

  1. Make sure your graphics card drivers are up to date.
  2. Make sure Windows and Steam are both up to date.
  3. Download a fan speed control software, and adjust fan speed to a higher RPM. (try 100% and adjust down from there only if it works)
  4. Remove the sides of your cabinet and make sure there's a nice airflow.
  5. Uninstall the game and reinstall.

It is in general good to use trial and error with your video settings. Try lowering them a bit. Your graphics card might not meet the requirements for the highest settings. Remember that the published hardware requirements for a game is often a minimum or recommended, not what's needed for the maximum settings.

If none of this works, I wouldn't be surprised if your graphics card fails within a short period of time.

  • I would love to know why this got down voted? It is an actual help.
    – AtlasEU
    Commented Jul 30, 2013 at 17:16

As other answers have suggested, this kind of error is most often caused by a physical hardware problem. In order to rule this out (and make sure you don't have to pay for a new graphics card), you need more proof than running other games at high settings.

One of the most common graphics card problems, which can vary from game to game (yes, even at high settings -- graphics drivers are fickle things) is overheating. Even if you are sure your computer is clean and the fan intakes/outtakes are not obstructed, you should still test the temperature of a few components while running the game and getting these artifacts. If you don't have a tool for monitoring temperature inside your computer, please download and install HWMonitor. If you find that temperatures on the CPU and GPU are within acceptable ranges and you're still getting graphical artifacts, you can move on to further tests.

It is important to update your graphics driver and verify the program files in Steam (after all, there may have been an update for this very problem). In general, though, be aware that the graphics engine in Civ 5 is not very optimized; it may stress your system a lot more than games with better effects, even at a low setting.

You have mentioned that you have a "pretty good computer", but specific part names (starting with your graphics card) would also help diagnose the issue. Especially if your graphics card is still within warranty, you may find that replacing it fixes the problem.


I've had something similar before. It turned out that I had a truckload of dust in & around the fan of my graphics card.

Removing the card, taking covers off and giving it a good work over with the vacuum cleaner fixed it.


I used to have some scrolling scan lines in the background. Switching from a VGA to an HDMI cable made them go away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .