4

In the optional mission, My Kingdom for a Wand in the Tiny Tina DLC, the last task is to shoot the Magical Orc in the head with a critical shot. I now have so many bodies piled up around the hut, that I can't always see him to stick the wand in.

I've tried sniper weapons, shotguns with bonus to critical chance, looking though sights to make sure his head is in the view finder, but I still cannot finish the mission. What am I doing wrong?

  • 1
    It is unclear what is wrong. Whenever the killing shot causes a Crititcal! text to pop out of the enemy, the mission should trigger. What exact weapons did you use to finish the mission? – Orc JMR Aug 10 '13 at 17:34
  • I still haven't finished it... I have seen the word CRITICAL many times. I've exited the zone, quit and restarted the game, and it's still not giving me the completion for the final part before taking the want back to Claptrap – SeanC Aug 10 '13 at 18:04
  • Dumb question, but have you tried using all types of weapons to see if it'll help? Also, try using a melee attack to the head for a finishing blow if possible. And you're not using Gaige for this quest, are you? – LOL. NO. Aug 11 '13 at 0:45
  • 1
    @SeanCheshire I see you've accepted my answer. Was it Interspersed Outburst that is causing the headshot to not register? – galacticninja Aug 11 '13 at 14:43
  • 1
    @galacticninja, it seems so - by reskilling, I was able to finish the quest. I promptly went back to my usual skilling after that – SeanC Aug 11 '13 at 17:21
2

Update: As of 2013-12-10, a hot fix has been released that resolves this issue. Related changelog:

Gaige's Interspersed Outburst no longer prevents critical hits from registering.

Before that hot fix, here's a workaround:

I found this post at the Steam forums that explains what may be the cause of the game not registering the headshot if playing as Gaige (My Kingdom for a Wand help | steamcommunity.com):

I had the same issue and had to respec because there's a bug with the Interspersed Outburst skill in the Little Big Trouble tree. The crits simply don't get registered and you're stuck shooting the orc in the face over and over again.

If you have a point in Interspersed Outburst, you might want to respec to remove that skill and finish that mission.

Also, try not to use elemental weapons or weapons with splash damage, to avoid the magical orc dying by elemental DoT or splash damage instead of the critical hit.

| improve this answer | |
  • as an update to this, the Hotfix from December 10th has resolved this issue – SeanC Dec 18 '13 at 20:57
  • @SeanCheshire I see. I have updated my answer with that info. – galacticninja Dec 19 '13 at 2:46
1

I just ran in to the same issue as Maya, UVM. It looked like one of her elemental skills was killing the orc right away. I tried phaselocking, non-elemental weapons, even grenades. Out of frustration I meleed the orc immediately after inserting the wand and it was instantly successful.

| improve this answer | |
0

The easiest way I found to do this was to bring a siren and phaselock the orc right after you insert the wand. It stops him from turning invisible and makes it easier to line up the shot (he turns invisible shortly after inserting the wand on Ultimate Vault Hunter mode, not sure about the lower difficulties). Make sure the siren doesn't have ruin/helios before phaselocking.
It also helps to use a non-elemental weapon with no burst fire or extra pellets. If I remember correctly, the orc is relatively easy to kill, even on Ultimate Vault Hunter mode; you'd be surprised how easily elemental damage can accidentally kill him.

| improve this answer | |
0

If Using Gauge just go right up to the hut and spam (E) to put the wand in and keep shooting.

I used a SMG and managed to kill the orc before Interspersed Outburst started stacking and mission complete

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.