1

I have just downloaded and installed Sleeping Dogs, and the binding editor in-game doesn't accept the arrow keys as valid inputs.

I'm left handed, so I can't really use WASD. I prefer not to use the numpad to move, and I don't want to play with gamepad.

I've tried to use AutoHotKey to remap the keys. I have written a script to swap the WASD keys with the arrows. I ran the script, entered the game and re-configured the keys. It seemed to be fine but somehow, in game, I can't use the arrows, even that they are mapped as the WASD keys (I can even try "WASD" with the arrows alone).

Is there any way to bind the arrow keys in Sleeping Dogs? (By mod / editing the game files / 3rd party software / etc.).

1
  • Quick question: have you tried ijkl or oklm? If you're touch typing, you're already going to be near those keys anyway.
    – Nzall
    Apr 9 '14 at 21:13
3

Unfortunately it is not possible to re-map the movement to use the arrow keys in Sleeping Dogs itself. There is a rather large topic on the official Sleeping Dogs forum where a lot of annoyed individuals have vented their frustrations.

It also seems that the developers have decided that a Third Party solution to the problem is adequate and it is unlikely that it will ever be fixed directly in the game.

I can see via your edit that you have found AutoHotKey but are having some issues. Have you remapped the arrow keys to something else (key pad is the most suitable I'd think). By default, I believe the arrow keys are used for the in-game mobile phone. If you haven't remapped these, I guess there is a conflict.

In the topic I mentioned earlier, I found a quick tutorial to set up AutoHotKey from the user "Bamamsterdam", so thanks to him:

  1. Install "AutoHotKey"
  2. Run it.
  3. Right-click on the icon in the system tray and select "edit this script".
  4. Keep or delete the text (doesn't matter).
  5. Copy and paste the below commands into the script
up::w  
down::s  
left::a  
right::d  

Numpad8::up  
Numpad5::down  
Numpad4::left  
Numpad6::right

NumpadAdd::Enter  
NumpadEnter::Backspace
  1. Save and you're done.

Hope this helps and that you can now play the game.

1
  • It does, thanks a lot. I must say, it's extremely odd issue. Square Enix are so lazy.
    – matan129
    Aug 15 '13 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.