2

I can't start CK2's launcher (ck2game.exe) due to problems with Nvidia drivers for my Optimus+Ion netbook, so I can only launch the game directly (ck2.exe). The usual way to activate DLC is to select it in the DLC list in the launcher, though. Is there any other way to activate DLC?

  • Contact technical support? – Resorath Aug 21 '13 at 18:57
  • First things first: Does your netbook meet the minimum requirements for the game? If it does, why don't you tell us what happens when you try to launch it on your netbook? – Frank Aug 21 '13 at 18:58
  • @fbueckert game work fine, but launcher (using to activate dlc) does not start. – couchemar Aug 21 '13 at 19:00
  • So what error do you get? Do you even get an error? We need more info in order to help you with this. – Frank Aug 21 '13 at 19:06
  • 2
    One of our mandates here is to solve the primary problem a user faces, not necessarily answer the question as stated. In this case, it's that the launcher doesn't work, meaning you can't play DLC. Immediately, there's two obvious avenues for attacking the problem: fix the launcher, or somehow bypass the launcher while still allowing DLC. A good problem solver will attack as many avenues as possible until a solution is found. That's why fbueckert is asking about the launcher. – MBraedley Aug 21 '13 at 19:34
3

This isn't a complete solution.

Launching the game via Steam -> Launcher -> Game appears to do some magic, aka it seems to trigger verification of DLC ownership that launching the game via just ck2game.exe -> Game or just ck2.exe does not.

Regardless, the launcher passes through various parameters to ck2.exe to set which mods to load and which DLCs to exclude:

  • -mod=mod/[mod name]
  • -exclude_dlc=dlc/[dlc name]

For example, this would theoretically launch the game with 2 mods enabled and 2 DLCs (Russian and Mediterranean Portraits) disabled:

"C:\Programs\Games\Steam\steamapps\common\Crusader Kings II\ck2.exe" -mod=mod/Realign_Celts_Men.mod -mod=mod/Edits.mod -exclude_dlc=dlc/dlc014.dlc -exclude_dlc=dlc/dlc016.dlc

However, knowing this to create a shortcut with these parameters will not work, as it does not invoke the magical Steam fairy that verifies the DLC ownership that allows them to load ingame.

Without that verification, you (mostly) out of luck. There is a way to get this to work...but the legality of that is questionable and probably can't be discussed here.

Hopefully the fixing the launcher path will be more fruitful.

2

Thanks all for the answers. The my way to fix launcher:

  1. install .net 4.5
  2. remove nvidia drivers
  3. reboot
  4. install nvidia drivers (same version that I used before)
  5. reboot

After this launcher works fine.

Also i check that Steam and CK2+DLC works fine on linux (i used Fedora 18).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.