2

I connected a PS3 to an Asus 24" Monitor (Asus PB248Q) via HDMI. The monitor does not have internal speakers but has a jack for headphones.

If I connect a headset to the headphones jack I can hear the audio in the main PS3 menu (for example, the clicks that sound when you are selecting a user).

However, if I load Call of Duty, there is no sound coming out of the headset. The volume is fully turned up (both in the monitor's OSD and in PS3). Sound stops in the switch to CoD.

I notice that when Call of Duty loads, "HDMI" appears a couple times on the monitor so I assume that Call of Duty is doing some kind of HDMI initialization that ends up turning off sound.

By comparison, if the HDMI connection is made to a Sony Bravia TV, then is sound is fine for Call of Duty so it seems an issue specific to this monitor that does not have built-in speakers. I wonder if Call of Duty does some kind of handshake at load-time with the monitor and then turns off sound if it does not detect built-in speakers

Is there any setting I can configure to solve this issue?

  • 1
    maybe something stupid, but are you sure that there is no sound at all and not just too low? Or maybe you turned it off in the game menu? Try setting it to the max in the settings of the game – Novarg Aug 22 '13 at 16:06
  • Did this issue only come up when you starting using HDMI with the PS3 or is it only when using HDMI with this monitor in specific? – user2414268 Aug 22 '13 at 18:24
  • @Novarg No, the volume is fully turned up (both in the monitor's OSD and in PS3). Sound vaninshes in the switch to COD. – Pep Aug 22 '13 at 19:04
  • @user2414268 If the HDMI connection is made to a Sony Bravia TV, then is sound is fine for Call of Duty so it seems an issue specific to this monitor that does not have built-in speakers. I wonder if Call of Duty does some kind of handshake at load-time with the monitor and then turns off sound if it does not detect built-in speakers. – Pep Aug 22 '13 at 19:07
  • 1
    @Cole No, that's a guess. We want answers to solve the problem, not maybe solve it. Tech support happens in comments. Once we've got it figured out, THEN we post it as an answer. – Frank Aug 22 '13 at 22:05
3

I would guess that game is using output format not supported by monitor. Select 2 channel HDMI and disable all audio output formats in options except for Linear PCM 44.1 and 48 kHz. See if that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.