Two weeks ago I borrowed an Oculus Rift for the weekend and installed some mods for it, following this guide. Now I'm trying to run it again without the Oculus, and it instantly crashes to desktop.


I click on Skyrim in my Steam library, and then click Play from the launcher. A console window pops up for half a second, closes, and the game doesn't run. Sometimes I see a black screen flicker up and then close.

What I've tried

  • Running Skyrim from SKSE. In this case, I see the SKSE console window flicker up, then another console window, and the game doesn't start.
  • Uninstalling all mods.
  • Deleting my Skyrim.ini and SkyrimPrefs.ini files.
  • Reinstalling Skyrim in Steam by clicking Delete Local Content, followed by Install.
  • Running Skyrim in a Window.
  • Praising Talos.
  • Changing Audio settings to DVD quality.
  • Restarting my computer.

System specifications

  • OS: Windows 7 Ultimate, 64-bit
  • Processor: Intel Core i5-4670K CPU @ 3.40 GHz
  • Drive: Samsung 840 SSD
  • Graphics Card:: AMD Radeon HD 7900
  • Motherboard: Gigabyte GA-Z87X-UD4H ATX LGA1150
  • Monitor: BenQ XL2420T


Per SevenSidedDie's recommendation, I deleted d3d9.dll, hijackdll.dll, and libfreespace.dll from my Steamapps\common\Skyrim\ folder. It's alive!

Generalized Solution

Uninstalling and reinstalling via steam does not remove the Skyrim folder. If you manually added any DLLs during the modding process, you may have to remove them manually as well. Alternatively, if you don't know which DLLs to remove, uninstall the game, delete the Skyrim folder, and then reinstall. You will not lose your saved games, since they are stored in Users\USER\Documents\my games\skyrim, rather than in steamapp.

  • 6
    +1 for praising Talos. Those elves don't know what they're missing.
    – shanodin
    Sep 2, 2013 at 16:54
  • 1
    I think you may have forgotten to actually +1... Sep 2, 2013 at 17:10
  • 1
    shush. I did no such thing.
    – shanodin
    Sep 2, 2013 at 20:33
  • 8
    I just read through the Oculus mods instructions and note that it tells you to dump a bunch of DLLs into the Skyrim install folder. Steam won't remove these, I believe! They are probably still there after a "fresh" install, and if so, likely are the culprit. Sep 4, 2013 at 16:19
  • 1
    @MatthewPiziak Done! I'm glad it worked. I didn't have the means to test it myself, so woo for teamwork. :D Sep 5, 2013 at 2:35

2 Answers 2


The guide you linked to has one step that tells you to dump a punch of Perspective DLLs into Skyrim's executable folder. Since Steam doesn't know these files, it will refuse to delete them! They will still be there when you do a "fresh" install, and will be injected into Skyrim whether you have the Oculus Rift installed or not.

Delete those DLLs, and Skyrim should be fine.

  • Thank you so much for your answer! I will award you the bounty as soon as Arqade lets me (13 hours after this comment was posted). Sep 5, 2013 at 2:37

I would try Verifying your Game Cache. But then I would of tried that before reinstalling. Right click on your Steam game in your library > Propertyies > Local Files > Verify Integrity of Game Cache

Also, good for you (and me when I had this same problem) this also resets your game settings (only for Skyrim, I believe). So your display driver/hardware will be re-found.

If this does not work then I can only assume that the Oculus Rift has changed your computer in some way that Skyrim does not like. I would try reinstalling/updating your video drivers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .