1

EDIT: Figured it out. Looks like in the other thread, the updated G&K directions were incorrect (at least for me). I simply followed the original directions and found the Controls.ModsButton:SetHide(true) and fixed it, per original instructions. Sorry for the duplicate! Thanks for all the help!

I looked at this link first: How can I enable Civ 5 mods on Mac OS X?

But I got stuck where it says Front End/Mainmenu.lua. Mine is a .xml file (not sure if that matters). Anyway, I opened it up using Text Editor on Mac, but couldn't find the "Controls.ModsButton:SetHide( true );" to change it. So now I am stuck. This is what it says instead:

  <GridButton Anchor="C,T" ID="ModsButton"          Size="320,45"    Style="ZoomButton" String="TXT_KEY_MODS" >
    <ShowOnMouseOver>
      <AlphaAnim Anchor="L,T" Size="320,48" Pause="0" Cycle="Bounce" Speed="1" AlphaStart="1.5" AlphaEnd="1">
        <Grid   Size="320,48" Offset="0,-2" Padding="0,0" Style="Grid9FrameTurnsHL" />
      </AlphaAnim>
      <AlphaAnim Anchor="L,T" Size="320,48" Pause="0" Cycle="Once" Speed="1" AlphaStart=".2" AlphaEnd="0">
        <Image Anchor="R,C" Offset="0,0" AnchorSide="O.I" Texture="Assets/UI/Art/WorldView/WindowGlowRight.dds" Size="42,86" />
        <Image Anchor="L,C" Offset="0,0" AnchorSide="O.I" Texture="Assets/UI/Art/WorldView/WindowGlowLeft.dds" Size="42,86" />
      </AlphaAnim>

    </ShowOnMouseOver>
    <Image Anchor="C,T" AnchorSide="I.O" Offset="0,0" Texture="bar300x2.dds" Size="300.1" />
  </GridButton>

If you want the whole text, I can post it. But nothing that I saw suggested a "hide mods button" so I'm not sure what to do next. I have Gods & Kings as well. Help!

6
  • There are several Mainmenu.lua files being referenced in the answers of that question. Are you sure you're looking at the right one? – Frank Sep 3 '13 at 15:30
  • @fbueckert I followed this direction from the other Question: Library/Application Support/Steam/SteamApps/common/sid meier civilization v/Civilization V : Gods & Kings/Contents/Home/assets/DLC/Expansion/UI/FrontEnd/MainMenu.lua But that last MainMenu.lua is MainMenu.xml in mine. There IS a MainMenu.lua, but it is under assets/UI/FrontEnd, which is not the directory to follow if you have G&K (which I do), according to Private Pansy. – Nav Sep 3 '13 at 16:12
  • They might have changed it again. Do you have Brave New world as well? It might be worthwhile to update the existing answers on the other question. – Frank Sep 3 '13 at 17:00
  • I dont see how this is a duplicate question. The other thread that this is supposedly a duplicate of did not help me figure out my problem, which is why I am asking again. Will someone please help me? – Nav Sep 4 '13 at 21:20
  • 1
    @fbueckert I'm sorry, I'm brand new to this site. I do have G&K but not BNW (I bought the Gold edition, so I don't believe it comes with BNW). Like I said, I followed the method for G&K in the other thread, but I did not find the MainMenu.lua under the Civ5Gods&Kings/Contents/Home/assets/DLC/expansion/UI/frontend; I found MainMenu.xlm instead...I did however find MainMenu.lua but it was under Civ5G&K/contents/home/assets/UI/Frontend/MainMenu.lua, which is not where to go if you have G&K (according to the other thread instructions). Thank you for helping me, I really do appreciate it! – Nav Sep 5 '13 at 1:00