3

I am trying to launch Amnesia: A Machine For Pigs, but it doesn't want to open. It says that it's going to open and then it just doesn't. It's currently the only game I have installed.

Here's specifically what's happening.

  • I click "Play" and it asks if I want to go to the settings or play the game.
  • Clicking either one will pop up a little "Launching" box for a millisecond, and the title in my library will go yellow for a millisecond, then nothing else happens.

I have tried:

  • Uninstalling and reinstalling
  • Verifying Integrity of Game Cache
  • Updating & Restarting my computer
  • Running Steam as Admin
  • Launching the game from a newly created desktop shortcut

But still no luck. Is there something else I need to do? I have checked my firewall properties and both Amnesia and Steam are allowed on public and private networks.

My System Specs (if relevant):

  • Windows 7 64bit (SP1)
  • Intel Core i5 Processor
  • 4GB RAM
  • 1
    Have you tried installing it and then restarting steam? – Lawton Sep 11 '13 at 0:49
  • 1
    Updated my computer, restarted my computer, verified its integrity. Still a no-go. – Howdy_McGee Sep 11 '13 at 1:09
  • 1
    Have you tried running as admin, or running directly from the .exe rather than from the client? Also you should say whether this is the new or old amnesia. I'm assuming its the new one but ive had similar issues with other games – Lawton Sep 11 '13 at 1:18
  • 1
    It is the new amnesia, but I didnt think it mattered as it's most likely either steam or windows issue. Running as admin didn't help :/ - Created a desktop shortcut, didn't help. – Howdy_McGee Sep 11 '13 at 1:23
  • 1
    @Howdy_McGee Yeah I was just asking for tagging purposes, I think its a steam issue. It looks like amnesia is DRM free, so you should just be able to go into the steamapps/common/ folder and run the main exe to play though. – Lawton Sep 11 '13 at 1:27
6

Based on complaints on the steam community forum the game is currently broken for a number of people.

However, the asker was able to solve the problem by downloading a .dll file here. Apparently steam is not downloading .dlls appropriately on some x64 systems

0

I don't know if you've tried this or not, but it worked for me! In your Machine For Pigs folder, delete the three following files; xinput1_3.dll, msvcr100.dll and msvcp100.dll. They aren't actually needed for the game, but they cause this issue. =)

  • Based on the accepted answer the problem was one of these dll's missing...So removing a couple more isn't going to help. – Arperum Sep 12 '13 at 11:48

protected by Community Sep 12 '13 at 11:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.