7

Can somebody please tell me how to prevent creeps from spawning in DotA? I have Googled it but can't find a command that will achieve this.

I have tried -killall , -spawnoff , -disablecreepspawn, but nothing helps.

1
  • Please refrain from using WoW tags for questions related to DotA in the future ;)
    – Nolonar
    Sep 13, 2013 at 12:11

1 Answer 1

5

You can use:

  • -killall: kill all creeps on the map
  • -killsent: kill all Sentinel's creeps on the map
  • -killscourge: kill all Scourge's creeps on the map
  • -spawnoff: disable the spawn of creeps

However these commands will only work in single player mode. Which means you can't go in Local Area Network, create a game of DotA and use them. You have to go in single player > custom map (I don't remember the menu's name exactly) and then play a DotA game where you will be able to disable creep spawns.

At the very beginning of the game:

  1. Type -test and press Enter
  2. Type the game mode (-ap, -sd or even -ardmemomnpfr if you feel like it) and press Enter
  3. Type -spawnoff and press Enter

The -spawnoff command was added in the 6.66 patch and you have here a list of all the commands you can use.

4
  • Mate as i have told i have tried all of these commands but nothing works..other commands like cm , dm all are working but not these..
    – waris
    Sep 14, 2013 at 13:55
  • @waris Check your version of DoTA - you need at least 6.66 and higher. Also, you may have to enable cheats if trying to do this on a Battle.net game (I forget the command for that, but it may just be turning WTF mode on with -wtf).
    – Kotsu
    Sep 14, 2013 at 14:55
  • @waris Have you explicitly typed "-test" at the begining of the game ? before heroes are loaded in the tavern
    – WizLiz
    Sep 16, 2013 at 12:23
  • Thanx it worked.
    – waris
    Sep 16, 2013 at 18:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .