17

I'm playing as a khajit in skyrim, going to assassinate Beitlid in Dawnstar. Now, the first time I did it on her porch and just killed her with the Blade of Woe. I got caught somehow, whatever, so I loaded a previous save because mid-jailbreak the guards decided to just attack instead of attempt an arrest.

Then I tried sniping her... and now my arrows have FED, Flight Erectile Dysfunction. They fly... like two feet before suddenly dropping off. It's weird. It doesn't matter how long I hold the trigger, it just droops.

  • 1
    Since this is a question about a glitch, can you tell us what platform this is on? If PC, are you running any mods? – Studoku Sep 13 '13 at 18:33
  • @Studoku - PS3 so no, no mods. – Selonianth Sep 13 '13 at 18:36
  • I've seen this happen a lot but it always seems to be temporary. It might be due to how saves work on PS3 though I do not know. I have not seen any correlation to specific actions causing this however. – James Sep 13 '13 at 18:39
  • You should consult your doctor if you experience symptoms of FED. ;) In all seriousness, this is a good question; +1. – Jonah Bishop Feb 13 '14 at 21:08
13

This is a known issue across all 3 systems:

When shooting certain kinds of arrows, the bow string might go 'limp' and the arrow will fly its minimum distance and with minimal damage. It happens even if the bowstring is pulled back fully, with lighter bows and arrows and even when staying still. To fix, try using a different bow or arrows until the glitch ceases. Especially frustrating when engaging powerful enemies or when using magic bows who lose charge per shot regardless of a hit or miss.

  • 1
    …until the glitch ceases. Which is when? What causes it to end? Time? Movement? Shots fired? Something else? In other words, what can be done to expedite the end of the glitch? – Synetech Sep 13 '13 at 19:06
  • 3
    @Synetech from what I understand (reading the forums about others having this issue), its shots fired. So shoot a lot of arrows until the glitch ends. – l I Sep 13 '13 at 19:08
  • 1
    @Synetech there's always the age old go to solution tinyurl.com/njxm7ab seriously though restarting the game or simply changing area either by fast travelling or entering a building fixes a lot of problems – IG_42 Jan 29 '15 at 21:28
7

If you have the Dragonborn expansion, you might also be using Riekling Spears instead of standard arrows. The spears are much heavier than arrows, and do not fly nearly as far when shot. When you run out of arrows, the game might have automatically switched you over to spears.

5

Ok.
I was getting really irritated because I was having the same problem.
Read the solutions and none of them worked.

I was determined to find a solution so I did.

  1. Put multiple kinds of arrows in your quick inventory.
    (Up on the dpad for Xbox 360 [y from items list to put them in there])

  2. In first person draw your bow

  3. With bow still drawn select a different arrow in the quick list

  4. Try and it will shoot correctly.

1

I found how to stop that glitch. At least for me it worked: Just shoot any arrow without holding the bow at all. Like just do a quick powerless shot, and then you should be able to shoot as before!

0

Just switch between types of arrows and fire one off until the glitch debugs, I tried foresworn, iron, steel, elven, and dwarven before it debugged. don't waste, recover after as they land in a pile.

0

Just shoot a lot of arrows till the glitch disappears, if that doesn't work then favorite every kind of arrow that you have in your inventory then equip your bow and hold the button used to draw then equip a different type of arrow and shoot, hopefully it works

0

To fix the problem just keep firing arrows. You got some faulty arrows. Don't pick them up again. Has nothing to do with the bow, the bow is fine.

protected by Frank Jun 10 '15 at 23:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.