0

I'm not sure, but it seems like the requirements for valid housing have changed in Terraria 1.2.

I usually build a big central chamber like in the image below, but since the 1.2 patch this setup doesn't work. The query tool give the "This is not valid housing" message.

The room is enclosed by bricks and platforms. It has a door, chair, table, background walls and light sources. This was usually enough for valid housing.

Central room is not valid

Have the requirements for valid housing changed in Terraria 1.2? If so, what are the new requirements? Or am I just doing it wrong?

Edit/Answer:

For those that don't find any answer in the "duplicate" question: Rooms have a max size. The exact maximum is elusive since there are a lot of variables. This forum post has a nice guide about house size.

  • I'm assuming that the central upper area has not enough light – Arperum Oct 3 '13 at 10:25
  • Could be a bug, because "traditonal" housing still works exactly like it used to. – peacedog Oct 3 '13 at 10:36
  • Where is the answer in the linked question? As already stated in this question I think I have the standard requirements right, and I wouldn't say my room is too small. After some additional testing I would say that it might be too big, but I see nothing about that in the linked question. – Arahman Oct 3 '13 at 17:57
  • 1
    You need a space of 3 solid floor blocks inside the door for the NPC to stand on while in their house, and it looks like you only have 1-2 solid floor bricks by both your doors – Rachel Oct 8 '13 at 1:16
  • I tried to change every floor tile into bricks, and also removed the platforms in the windows, but it still doesn't work. Only thing that worked so far is dividing the room into several smaller chambers. – Arahman Oct 10 '13 at 8:24
2

The requirements for housing do not seem to have changed in 1.2, you still need walls, background walls, a light source, a "Comfort Item" (chair), a "Flat Surface Item" (table) and a door.

It also needs to be at least 8 by 4 or 7 by 5 on the inside, and not near too much corruption.

You can get the error "This is not valid housing." if you do not fulfill the walls, background walls or minimum size requirements. Your problem is likely that, although some windows are allowed, the big window in the center might be too big, try making the window less tall (sorry, it looks really cool as is).

Source: http://terraria.wikia.com/wiki/Home

| improve this answer | |
  • 1
    I tried to fill in the windows without any luck. Then I found that it seems to work if I divided the chamber into three parts with the central window in one room. I might be hitting some max size, which is strange since I think I have built larger than that before. I can't access it the next few days, but later I will try loading an old save and see if my old big rooms still work. – Arahman Oct 3 '13 at 17:22
  • I'm having a problem with the room being too large also. No windows or anything and plenty of torches, tables and chairs – VanBuzzKill Oct 6 '13 at 17:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.