8

I have had the game, Terraria for a while and it has always worked fine for me. Recently, a new update, 1.2, came out, and Steam updated the game to that version. After that, Terraria no longer starts up. Even if I run it as administrator, or from cmd. From cmd, there is no error. After entering the command, I am immediately allowed to type again. Nothing happens at all. I do not see any dialog telling me Steam is starting the game, but my friends are told that I am playing it, then that I am no longer playing it, shortly after.

Here is the error I found in Event Viewer:

Application: Terraria.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException
Stack:
   at Terraria.Main..ctor()
   at Terraria.Program.Main(System.String[])

Here's what I've done to fix the problem:

  • Reinstall Terraria
  • Reinstall the XNA Framework 4.0
  • Did not reinstall .NET, but it works with Visual Studio (version 4.5, which is technically just an update to 4.0). Plus, I repaired it, which is, so far as I know, an equivalent to reinstallation.
  • Verify game cache integrity. This is the strange part. I am always told that the cache is invalid, then Steam redownloads the required file, and the cache is invalid after verifying again.
  • Restarting my computer
  • Repairing the XNA Framework in the Terraria folder
  • Set Terraria to compatability mode for XP SP2, which worked for the initial update, but a new bugfix makes it so that no longer works.

Here are my system specs:

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
OS Manufacturer Microsoft Corporation
System Manufacturer LENOVO
System Model    IdeaCentre K430
System Type x64-based PC
Processor   Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz, 3001 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date   LENOVO E8KT24AUS, 2/16/2012
SMBIOS Version  2.7
Windows Directory   C:\Windows
System Directory    C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale  United States
Hardware Abstraction Layer  Version = "6.1.7601.17514"
Time Zone   Eastern Daylight Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory   16.0 GB
Available Physical Memory   8.21 GB
Total Virtual Memory    31.9 GB
Available Virtual Memory    22.4 GB
Page File Space 16.0 GB
Page File   C:\pagefile.sys

What can I do to get the game to work? I can verify that it did work before with .NET 4.5, so that is not the problem. Can someone help me get a hint as to what's wrong? Thanks.

  • 1
    Is your PC particularly old? If you bought Terraria when it first came out, and your PC was lower-end at the time, and it hasn't been upgraded or changed since then, the jump in required processing power or other hardware requirements may be causing it to shut down before it fully starts up. Or you could lack some other software/hardware installation necessary, like new graphics card driver or other such things. This is...unlikely if it's just Terraria having trouble though. – Zibbobz Oct 4 '13 at 19:27
  • 2
    @Zibbobz the standard of the computer wouldn't impact on whether the game is able to start or not. Even if it was a lower end machine, it would still launch the game. – shanodin Oct 5 '13 at 3:48
  • 1
    You mentioned that "this version of .NET is actually an updated version of the one Terraria typically uses." Have you tried downgrading to the version it typically uses? It's possible 1.2 has a bug only triggered by the newer .Net. – SevenSidedDie Oct 11 '13 at 3:56
  • 1
    One thing to note is that installing .NET Framework 4.5 doesn't automatically mean any game that needs the framework will work; they're all different. You need the one that comes with the game itself. – Frank Oct 11 '13 at 14:22
  • 1
    @Dillmo What worked before the update is obviously not relevant. It's crashing now and wasn't then, so all bets are off. Downgrading .Net, even temporarily, is something you haven't tried. Try it? – SevenSidedDie Oct 11 '13 at 14:45
5

According to numerous sources (one, two) it's in fact related to .NET installation. In order to repair it, you need to uninstall both XNA Framework, and .NET Framework.

Using "Programs and Features":

  1. Uninstall Terraria
  2. Uninstall all XNA stuff
  3. Uninstall all .NET Framework stuff ("extended" must be uninstalled first!)
  4. Reboot
  5. Reinstall Terraria and let it reinstall the .NET and XNA stuff.
  • Here's some background knowledge on why I don't think this will help: When I first updated Terraria to v1.2, I had the same issue, but was able to fix it by setting it to compatibility mode for Windows XP SP2. Upon updating to a bugfix, the same issue popped up. However, the same fix did not work. I have tried reinstalling both frameworks. This is where I'm at. – Dillmo Oct 11 '13 at 11:10
  • 5
    @Dillmo - How about you try the suggestion before you dismiss it? – Ramhound Oct 11 '13 at 12:41
  • Thanks. You did help me fix my problem. Apparently it was not a problem with .NET or XNA, but a missing dependency. Terraria worked before because it made not calls to .NET Extended, but now that it does, it stopped working. So, by installing .NET 4.0 Extended, I was able to fix my problem. – Dillmo Oct 11 '13 at 16:23
  • @Dillmo glad that helped somehow in the end. Terraria is a great game :) – Petr Abdulin Oct 12 '13 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.