-1

I'm trying to run this XNA-based game on my Windows 7 32-bit laptop and it just won't run. No error messages, nothing.

If I have the Task Manager open I see the process being executed for a few seconds and disappear.

  • Clicking on the game file gives no result.
  • I have installed the XNA Frawemork latest version.
  • I have tried using the game installer, it installs but the game still won't run, whilst on another computer (Windows 7 32-bit laptop as well), the game runs fine without even needing to install.
  • I see I'm getting downvotes. What can I do to improve the quality of this question? – That Brazilian Guy Oct 4 '13 at 2:08
  • 1
    If the developer himself can't figure out what's wrong, I'm not sure what we can do to help… – SevenSidedDie Oct 4 '13 at 3:25
  • Do you have Games for Windows installed? It's a llllooooonnnnngggggg stretch, but it could be looking for another library that wasn't included in that framework? It's just a guess. – Cole Busby Oct 4 '13 at 6:02
  • 1
    Have you checked the event viewer for any error logs? You might see an .net exception in there – George Duckett Oct 4 '13 at 7:00
  • 1
    @ThatBrazilianGuy Control Panel->Small icons (Just to show administrative tools)->Administrative tools->Event Viewer – Cole Busby Oct 4 '13 at 15:44
1

Xna is built on .Net so there's probably some clue as to what issue is in the event log.

You'll find the event log under administrative tools in the control panel (viewable when control panel is set to "small icons").

  • There were a dozen events with Event ID 1026, the most relevant line reading Microsoft.Xna.Framework.Graphics.NoSuitableGraphicsDeviceException. Damn. – That Brazilian Guy Oct 5 '13 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.