1

I've had Civilization 5 for a year or so now and every time I wish to add a mod I go in and click the "Subscribe" button and nothing happens. So if anyone has had this problem can they tell me how to fix it please.

7
  • 2
    Define "nothing happens". – kotekzot Oct 4 '13 at 10:14
  • When I scroll down and click on the green button with the plus and the word "subscribe" on it literally nothing happens at all. nothing tries to load, nothing changes on my screen and when I tried to launch it in a new tab, still it only created a new tab and then stopped dead. Does that help? – LF6130 Oct 4 '13 at 21:39
  • Update the browser you're using to subscribe, try a different browser if that fails (Steam Clients counts as a browser). – kotekzot Oct 4 '13 at 21:43
  • Do you mean changing from Chrome to Internet Explorer? (for example) – LF6130 Oct 5 '13 at 0:48
  • 2
    One more thing: are you playing on PC or Mac? Civ 5 on Mac does not have mod support, which Steam does not acknowledge anywhere. Last I checked, I could subscribe to mods, and Steam would actually say it's downloading them, but there is no dialog for enabling mods in-game, and last I checked, there is not even a way to hack in partial mod support anymore, as there was early on. My understanding is that for some technical reason Aspyr couldn't make all mods function the same on Mac as on Windows, so they disabled the feature instead. – Theodore Murdock Nov 5 '13 at 3:46
-1
  1. Find the latest version of your browser
  2. Download it
  3. Install it
  4. Subscribe to mods in workshop
  5. Close the game
  6. Reopen the game
  7. Go to mods in the menu screen
  8. Check for a change

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.