8

I recently acquired a second monitor and installed it with an HDMI cable. Since then TF2 has been choppy, even though I have high FPS and a low ping. Does anyone know how to fix this problem? My guess is its something to do with the second monitor. I have a GTX 760 that outputs to both monitors.

Specs: i5-4670k, 8 GB RAM, Windows 7. That should be everything relevant to this problem.

8
  • Are you running TF2 in fullscreen or windowed mode? Commented Oct 8, 2013 at 6:33
  • @Shadur I'm running it in a borderless window. Commented Oct 8, 2013 at 19:36
  • If you remove the second monitor from your setup, does the problem persist? If you run it in full screen mode with the second monitor, does the problem persist?
    – Colin D
    Commented Oct 10, 2013 at 20:23
  • Are you running with the most up to date video card drivers? Can you provide the rest of your machine spec? cpu, RAM, OS, ect...
    – Colin D
    Commented Oct 10, 2013 at 20:26
  • 1
    I'm not on SLI. Commented Oct 11, 2013 at 2:36

1 Answer 1

8
+50

Try turning off the Aero theme and seeing if your performance improves.

A somewhat common issue with some NVidia video cards on Windows 7 with multiple monitors is that the Aero theme can cause display lag/stuttering.

Guide for turning off the Aero theme:

  1. Start Button > Control Panel > Personalization
  2. Select any of the themes in the Basic And High Contrast Themes category.

Visual guide for turning off the Aero theme: (scroll down to the Windows 7 section) http://www.howtogeek.com/howto/windows-vista/disable-aero-on-windows-vista/

3
  • 4
    I toggled it on and off and now it's working fine. Huh Commented Oct 11, 2013 at 2:57
  • @sommerjj Glad to hear that it worked.
    – Lemmings19
    Commented Oct 11, 2013 at 5:23
  • 2
    @sommerjj If that's the answer who helped you, don't forget to accept it ^_-
    – WizLiz
    Commented Oct 11, 2013 at 16:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .