I've tried to connect to servers for games like Garry's Mod, Dota 2, CS:GO and none of them have worked I get a error message like this: enter image description here

I've tried port forwarding, virus scanning, disabling firewall, reinstalling ClientRegistry.blob and AppUpdateStats.blob, DMZ mode, allowing steam through firewall, verifying game cache and none of it has worked. The weird thing about it is that only a handful of servers work but not all of them.

  • 1
    What kind of network is this? If you are doing it at a school or something it might be blocked.
    – Batophobia
    Oct 10, 2013 at 16:43
  • I'm doing it on my home connection, leeching off my neighbors (my uncle) he's trying to help me get this sorted. Not sure if this is a computer problem though, I've been trying to look into my lan card which is a Realtek PcIe GBE Family Controller, I can't rollback the driver.
    – Lordrice
    Oct 10, 2013 at 19:38
  • For clarification: This happens ONLY to Valve games (try TF2)? This happens on all servers you try connecting to? Not to get too personal but where are you located (country)? Are you trying to connect to foreign servers? Have you connected to any of these servers before?
    – Batophobia
    Oct 10, 2013 at 19:47
  • I've been having issues with all kinds of games Trine 2, Team Fortress 2, etc mostly games with source servers. This happens to a majority of servers I try to connect to, only a handful of servers work for me. I am located in the U.S, New Mexico. And no, not trying to connect to foreign servers, I connect to the ones located in the U.S.
    – Lordrice
    Oct 10, 2013 at 21:15
  • Are you using peer block? If so, try disabling it.
    – user65645
    Jan 2, 2014 at 17:09

1 Answer 1


Try disabling/enabling Steam Beta participation and if that fails, try deleting appcache and even your Steam folder if you have to.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .