I get the quest from Galmar, but no Stormcloaks or Imperials are at the fort. I have tried everything I can think of but nobody shows to the party. There are three Imperials on the road, I have tried killing and not killing them, I talked to Ulfric, I hit Galmar and paid the bounty.

I didn't think those 3 imperials had anything to do with it but I have been trying everything. I'm on PS3, I have reloaded twice with the same results. I stopped here on the questline to do Season Unending (the peace treaty to kill Alduin).

Can anyone sort this out?


5 Answers 5


The imperials on the road have nothing to do with the quest and are just a random encounter.

There is a glitch that can cause the Stormcloaks not to spawn at the quest marker and the Imperials not to spawn at the fort. If this occurs you have one, maybe two options depending on your platform.

The simplest option is to reload a save from before you got this quest. This should fix it. If it doesn't, find an earlier save.

If you're playing on the PC, you could also use console commands to bypass the impossible stage. Open the console and type setstage 00083042 10. This should force everyone to spawn.


I recommend sleep 30 days as far away from Fort Hraggstad as you can so you can trigger a respawn.

It seems like the scripts for the area are not triggering properly. The chunk of the area can be unloaded by the game and re-loaded, with everything reset, if you wait long enough for an area respawn. Since it is hard to determine how much time you need, going for 30 days guarantees it to trigger.


This sounds like a glitch. Have you tried loading back to a previous save where you haven't started the quest yet? Maybe start the quest again? Maybe you're doing the quest wrong, missing some minor thing, like talking to a specific NPC or going to a specific point to start the quest. Here is a walk through video from YouTube on the quest you're doing.


There's another way that worked for me on the PC - the console command: setstage cwfortsiegefort 10.

  • Is this replaceable on the PS3? OP seems to have had this issue while playing the PS3 version of the game.
    – NBN-Alex
    Jun 30, 2016 at 18:37
  • They said it was on PS3 in comments, which I just edited into the question. Giving a PC solution in addition to the PS3 solution can be helpful for others with the same problem, but giving just a PC solution doesn't help the asker, which is the main thing we're doing here.
    – DCShannon
    Jun 30, 2016 at 19:01

Skyrim is such a big game so it gets laggy so just go back to the latest save before fort haggstard battle and go where you are supposed to go. If this does not work, I am sorry but your game is broken.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .