I installed Urban terror yesterday on my Mac OSX 10.9 and It refuses to launch, I just get a black screen and then it quits. It's in my applications folder. I ran it from the package>Contents>MacOS>Quake3-UrT.i386 and here is the log:

Last login: Thu Oct 31 17:33:21 on ttys000
IVCMBP-013:~ ivcmbp013adm$ /Applications/Quake3-UrT.app/Contents/MacOS/Quake3-UrT.i386 ; exit;
ioQ3 1.35 urt 4.2.015 macosx-i386 Sep 25 2013
----- FS_Startup -----
Current search path:
/Users/ivcmbp013adm/Library/Application Support/Quake3/q3ut4
/Applications/q3ut4/zUrT42_qvm.pk3 (3 files)
/Applications/q3ut4/zUrT42_0024.pk3 (253 files)
/Applications/q3ut4/zUrT42_0023.pk3 (21 files)
/Applications/q3ut4/zUrT42_0022.pk3 (88 files)
/Applications/q3ut4/zUrT42_0021.pk3 (12 files)
/Applications/q3ut4/zUrT42_0020.pk3 (348 files)
/Applications/q3ut4/zUrT42_0019.pk3 (472 files)
/Applications/q3ut4/zUrT42_0018.pk3 (145 files)
/Applications/q3ut4/zUrT42_0017.pk3 (109 files)
/Applications/q3ut4/zUrT42_0016.pk3 (12 files)
/Applications/q3ut4/zUrT42_0015.pk3 (34 files)
/Applications/q3ut4/zUrT42_0014.pk3 (25 files)
/Applications/q3ut4/zUrT42_0013.pk3 (6 files)
/Applications/q3ut4/zUrT42_0012.pk3 (173 files)
/Applications/q3ut4/zUrT42_0011.pk3 (48 files)
/Applications/q3ut4/zUrT42_0010.pk3 (26 files)
/Applications/q3ut4/zUrT42_0009.pk3 (139 files)
/Applications/q3ut4/zUrT42_0008.pk3 (377 files)
/Applications/q3ut4/zUrT42_0007.pk3 (2097 files)
/Applications/q3ut4/zUrT42_0006.pk3 (1136 files)
/Applications/q3ut4/zUrT42_0005.pk3 (557 files)
/Applications/q3ut4/zUrT42_0004.pk3 (1707 files)
/Applications/q3ut4/zUrT42_0003.pk3 (1168 files)
/Applications/q3ut4/zUrT42_0002.pk3 (1547 files)
/Applications/q3ut4/zUrT42_0001.pk3 (2122 files)
/Applications/q3ut4/ut4_jumpents.pk3 (8 files)
/Applications/q3ut4/ut4_commune.pk3 (150 files)

12783 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
...loading /System/Library/Frameworks/OpenGL.framework/Libraries/libGL.dylib:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Initializing OpenGL display
...setting mode 4: 800 600
Using 4/4/4 Color bits, 24 depth, 8 stencil display.
GL_RENDERER: Intel HD Graphics 4000 OpenGL Engine
Initializing OpenGL extensions
...GL_S3_s3tc not found
...using GL_EXT_texture_env_add
...using GL_ARB_multitexture
...GL_EXT_compiled_vertex_array not found
...ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: Intel Inc.
GL_RENDERER: Intel HD Graphics 4000 OpenGL Engine
GL_VERSION: 2.1 INTEL-8.18.26

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(8-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: multiple glArrayElement
picmip: 1
texture bits: 32
multitexture: enabled
compiled vertex arrays: disabled
texenv add: enabled
compressed textures: disabled
SDL_SetGammaRamp: Received signal 11, exiting...
----- CL_Shutdown -----
RE_Shutdown( 1 )

[Process completed]

Additionally following are the messages in Utilities/Console.

10/31/13 5:50:10.347 PM Quake3-UrT.i386[22814]: CPSGetCurrentProcess(): This call is deprecated and should not be called anymore.
10/31/13 5:50:10.347 PM Quake3-UrT.i386[22814]: CPSSetForegroundOperationState(): This call is deprecated and should not be called anymore.
10/31/13 5:50:11.317 PM Quake3-UrT.i386[22814]: CGDisplayBaseAddress is obsolete and returning NULL for display 0x42731c0

  • 1
    You probably need to install an opengl driver for your onboard graphics chipset – kalina Oct 31 '13 at 23:36
  • It appears to be segfaulting (that "signal 11" in the error log) when it tries to use an obsolete display function. Does Quake 3 itself run without UrT installed? – SevenSidedDie Oct 31 '13 at 23:41
  • I don't have quake-3, I downloaded Urban terror from their website. – ManicMonkOnMac Oct 31 '13 at 23:57
  • @kalina: I have osx 10.9, I think it obviously has the OpenGL driver for the onboard graphics chipset, I am sure apple does that. – ManicMonkOnMac Oct 31 '13 at 23:58
  • @kalina Apparently, UrT is using deprecated framebuffer access functions that it shouldn't be on Mac OS 10.7+. A graphics update won't solve that. – SevenSidedDie Nov 1 '13 at 0:15
seta r_ignorehwgamma "1"

You can add that line to your q3config.cfg. To edit it, open a new Finder window, hit cmd+shift+G, and paste ~/Library/Application Support/Quake3/q3ut4/ in the box, and when the folder opens, you'll see q3config.cfg. Just open that file with a text editor like TextEdit. If you don't have that file or folder (perhaps because you were trying to uninstall), open Terminal and enter:

<Full/Path/To/UrT>/Quake3-UrT.app/Contents/MacOS/Quake3-UrT.i386 +seta r_ignorehwgamma "1"

Hit enter and your game will launch with that setting.

So on my computer, that would be

/Applications/UrbanTerror4.2/Quake3-UrT.app/Contents/MacOS/Quake3-UrT.i386 +seta r_ignorehwgamma "1"

This bug apparently has to do with SDL and it seems unlikely that FrozenSand will upgrade their implementation to the newest version.

Setting r_ignorehwgamma "1" will disable in-game gamma/"brightness" controls, so you'll have to manually change it via System Preferences > Displays > Color > Calibrate. Once you create a new "high gamma" color profile, you can just click back and forth between it and your normal settings in the future.

Below is my original (and not very effective) answer...

I always get the deprecated call errors in Console every time I run Urban Terror, in Mavericks and even before Mavericks. It is NOT the source of the problem, nor is it a fatal error.

You CAN run Urban Terror under OS X 10.9 Mavericks. Those deprecated call errors can be ignored (for now at least). Anyone who says different is wrong :)

FIRST, as a potential shortcut, it may simply be a matter of toggling some settings in your config file. This doesn't work for everyone though.

Edit your q3config.cfg file:

On OS X, it's in /Users/~/Library/Application Support/Quake3/q3ut4/q3config.cfg

Open it in a text editor and find the line

seta r_fullscreen "1"

and toggle it off:

seta r_fullscreen "0"

You might also try setting r_mode "-1" and r_customwidth "1280" r_customheight "800"

If that doesn't fix it, follow these steps and hopefully you'll be able to launch the game again:

  1. Clean up with Onyx
  2. List item
  3. Reboot into Recovery mode
  4. Repair permissions
  5. Repair disk Reboot normally and try to run Urban Terror

So, first you need to clean up your system.

You can do it manually, or automate the process with Onyx. I recommend all Mac users have Onyx installed, but if you don't want to, you can do it all manually. (...you'll have to find your own instructions though! Search for "OS X execute maintenance scripts manually" "OS X rebuild dyld's shared cache" and "OS X cleaning caches.")

Onyx will automate the process. You can get it by searching Google for "Titanium Onyx"

Once you've downloaded Onyx, run it and open the Automation tab. Check the following boxes:

settings for Onyx

This will close all running apps and it may take about 20 minutes or so to complete. When it's done, you will have to restart your computer. BEFORE you hit execute:

Save the following instructions somewhere if you can't remember them: After Onyx runs and you reboot, boot into Recovery mode by holding command+R. Once Recovery mode boots, open Disk Utility. Select your hard drive in the list and click the "Repair Permissions" button. Once that runs, click the "Repair disk" button. When that finishes, reboot and see if Urban Terror will run.

Okay, now that you have all the instructions, hit Execute in Onyx and start the process.

I took all of these steps at the same time, I still don't know exactly what the cause is, but my theory is that there is some cached data in the GL driver cache that is messing with the game. Once you clean the system/user caches, you should be good... but may as well do a full cleanup and repair permissions and the disk in Recovery mode, just to be sure.


Urban Terror appears to be incompatible with Mac OS 10.7 and later, because the graphics function CGDisplayBaseAddress has been deprecated in Mac OS X's graphics system, for OS versions later than 10.6 (Snow Leopard). UrT is using that function anyway, then taking the result and trying to use it to access the display's framebuffer directly. Since Mac OS 10.7 and up doesn't offer direct framebuffer access, this function no longer works as it used to and is causing UrT to attempt an illegal memory access, which is why it's shutting down with a Received signal 11, exiting... message in the crash log.

There is no fix to make it work on OS X Mavericks. The Urban Terror team will have to update the game to use the graphics functions that are available in Mac OS X versions later than 10.6.

As workaround, you could downgrade to Snow Leopard (which you likely don't want, but would work), or use Boot Camp / Parallels / VMWare to run Urban Terror on a Windows partition.

  • I have another system that has 10.7.5, and it's working alright in that, but wifi for that is not working and I can't get 10.9 to share the connection vie ethernet cable to my 10.7 system : (((( – ManicMonkOnMac Nov 1 '13 at 0:20
  • I guess the deprecated it after 10.6 but now made it illegal. – ManicMonkOnMac Nov 1 '13 at 0:20
  • I have had no problem with 10.7, 10.8, or now 10.9. Something else is wrong, or I have something else that makes it work. Just running the vanilla Urban Terror client. – iynque Nov 10 '13 at 23:38

I don't know what was wrong, but now it's working. I didn't change anything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.