It appears this question is common but I don't see any solutions online.

I am stuck on the loading screen on my main account on WoW. I tried deleting the 3 folders mentioned here and tried repair.exe and restarted my comp. No luck.

What can I do to get this loading again? I tried not touching my comp and waited 3+ minutes on the loading screen but still no luck.

  • To help us understand what your issue is, do you even get to the character selection screen? If so, are you able to load other characters, or all characters have the same issue? – kazzamalla Jan 8 '11 at 3:59

Sometimes when this happens, it means the world server itself is down -- check to make sure that you can load other characters, on other continents. For instance -- can you make a new draenei or blood elf character (hosted on the Outland world server)? Can you load characters parked in Northrend? In an instance? Do you have the same problem on a completely different server?

If you are able to do one or more of the above, it is likely the problem is either location or character specific. In either case, it is likely that time will resolve the problem, as parts of the server are brought back up. If, on the other hand, the problem persists for several days, I would try opening a ticket, or speaking to someone on the customer service forums.


My solution was to create a character, open a ticket in game and tell them the problem. Within 20mins i tried my account and it worked! However i was put onto a different continent. The stone brought be back to my own where i resumed my quest

  • So it sounds like, as I mentioned, it was character specific. Glad you got it fixed! – Raven Dreamer Jan 8 '11 at 6:54

I had a very similar issue like this once and it turned out to be my graphic card driver. Keep those drivers up to date!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy