10

I'm not completely sure how it happened, but I got stuck in the perspective of my horse, even when it is dead. I'm not in 3rd person view, I'm seeing my character move around while the camera holds still where my horse is.

I can still move my character around and hit things, but I can't figure out how to make the perspective go back to my player. I also tried loading an older save but there are no saves recent enough where there is no glitch. If I can't find a way to fix it, I will just load my older save in Solstheim. Can anyone help me?

I am playing Skyrim on the PS3.

  • 2
    You're probably just in 3rd person mode. You can switch between 3rd and 1st person. – VanBuzzKill Nov 10 '13 at 18:06
  • 1
    Can you provide a screenshot? – user57112 Nov 10 '13 at 18:27
  • I was not in third person, because i was not riding the horse at the time.. it was like from the horses perspective as the player moves around without the horse. it might be a bit hard to get a screenshot from ps3 but i can try. – Ulsa2 Nov 10 '13 at 21:10
  • If I'm understanding what you're saying correctly - the "camera" is fixed in position like someone else is watching you, instead of the camera being inside your head in first person or following behind your back in third person? – Affine Nov 10 '13 at 21:38
  • 2
    That is certified weird. – SevenSidedDie Nov 11 '13 at 4:54
2

You could try something that will force the camera to change.

Such as:

  • sitting on a bench
  • smithing
  • enchanting
2

Easy fix: fast travel into a town horses can't enter like Whiterun.

Just had this issue and that's how I fixed it.

0

Try riding another horse and getting off that It worked for me

  • sadly i killed my horse so i cannot see where i am going evne if i fast travel to a stable D: lol i will jsut blindly do it. – Ulsa2 Nov 11 '13 at 22:05
  • 1
    well i succesfully mounted a horse and dismounted. it was stolen.. but i think it shouldve done the trick. it Didnt. – Ulsa2 Nov 12 '13 at 5:06
0

I take it you have tried turning the game on and off? If that did not work, try reverting to an older save file than the time it happened. If neither of them fix it, then I am out of ideas.

0

try entering a building or hold then your technically in a different room all together that should reset your camera in the loading screen... if that doesn't work and you've tried all the other fixes people have said earlier then I'm afraid it may require reloading an earlier save and starting from there.

0

I just got that bug, I think, but I was using the carriage, I got stuck into a fixed point third person camera ( I couldn't even turn my view ) Bu I was able to mount a horse and move around until I found an interactable object, easiest for me ( and closest ) was a saw mill. I just went and tried to use the log pile to force the camera to change position to be behind me during the animation and force the next step to return to my character.

For me it really did the trick. I think going for a forge, a tannery and all this... Or like I just said, a sawmill, maybe it will work out.

-1

I had the same problem with Blaze, a horse added by "Blaze of Eventide." I uninstalled the mod which reset the view, possibly because the anchor for the view no longer existed. Maybe you could try to install a horse mod, console command the item to get the horse to you, and finally mount/dismount.

  • 1
    The question is for the PS3 version of Skyrim. No mods available. :-) – idan315 Jan 30 '14 at 6:36
  • 1
    Oh wow, totally missed that. :\ – gfritz Jan 31 '14 at 14:52
  • If the question was tagged PS3 that would have helped too. As it is an engine bug, certain mods e.g. Joy of Perspective can only increase the likelihood of it occurring especially when reloading from within the game and not from the game menu. – Laurie Stearn Nov 23 '17 at 10:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.