1

Ok so I put my freighter in my wing and everything was fine until I left Watergate and it stayed behind.

There are NO options for commands or even the most abstracted of manual control options.

I tried removing and re-adding to wing but that doesn't seem to have an effect.

Is my freighter STILL loading 100 energy cells on it? None of its cargo drones seem to be active.

What do I do?

Is anyone else getting this? (put in comments)

EDIT:

Upon further play I returned to the place where you buy energy cells with my freighter, ordered him to buy 200 and.... he engaged jump drive to another sector... (rage and profanities censored)

  • I ran into this EXACT issue, had no idea what the heck was going on. It was just sitting there stuck on trying to buy 100 energy cells and not doing anything. – l I Nov 16 '13 at 0:27
  • No solutions yet? :( I'm still sitting, tried removing from squad but then you can't buy. Also you can't give it any commands except assigning to a station/ship. – Sellorio Nov 16 '13 at 0:48
  • At least in previous games when the AI was being **** we could do it manually :/ – Sellorio Nov 16 '13 at 0:59
  • well the egosoft page seems to be down :P – l I Nov 16 '13 at 1:13
  • I noticed... It was down 7 hours ago too. Sigh – Sellorio Nov 16 '13 at 1:15
1

Ok so here is what I did, went smoothly without a hitch on 2 occasions (I accidentally bought the first 100 from Array I instead of Array II).

  1. Fly there
  2. Wait for transport (may be optional but I wouldn't risk it). Use Enter->2->2->"DE" to see sector location.
  3. Move close to purchase point (make sure its Array II) and use trade menu (Enter->4) to purchase the cells. At the bottom it will say where you are purchasing from. Make sure its Array II.
  4. Wait for transport to arrive, trade and confirm completion
  5. Laugh with joy, relief and exhilaration (hey that's just what I did!).
  6. Fly to destination
  7. Wait for freighter and then use trade menu to trade resources back (don't forget to wait patiently near the port).
| improve this answer | |
  • Just a matter of a day off (playing X3 of course) and research. Everyone is having that problem xD – Sellorio Nov 16 '13 at 21:10
0

I haven't finished the quest yet, but I believe the trick is to hail the freighter, give it an order to take you to the system with the quest (it'll be the one in orange text), then board the freighter and watch it go there. I don't know if you have to stay on board for all of that, but for some reason I only had "Take me to..." where I thought there'd be a "please go to..." - maybe because it's in your squad?

I have it in the target system now, so it's time to see if it'll execute the buy order...

EDIT: If you somehow have a glitch such that it has planned trips before you've bought 100 energy credits, I think you're screwed. I started over.

This time, the ship followed me (slowly) to the target system. I think getting there too fast and taking the suggested "mission while we wait" causes the freighter to stop trying to do the trip and follow you instead. The guidance I saw says to let it get there, then buy, let it finish loading the buy before doing a side mission or even skipping the side mission entirely.

| improve this answer | |
  • Yup i managed to get it to go to the right place (using that trick since it wouldnt follow me otherwise). But my purchase instruction shows up as a 'Planned Trip'. No idea what to do with that.. it just sits there. – Sellorio Nov 16 '13 at 4:04
  • Oh and for some reason if a ship isnt in your squad it seems like you cant give it ANY commands (other than assigning to station or ship). – Sellorio Nov 16 '13 at 4:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.