1

I have a problem with my main map on my server (1.6.4) where it uses ~2GB ram and no players. I know it has something to do with the map as I can watch the ram usage skyrocket when the map starts to load. Other than "cannot keep up message" and the server crashing when it runs out of RAM, I am getting no warnings.

I have tried to resolve this by:

  • Replacing Bukkit 1.6.4 with stock Minecraft 1.6.4 (no mods at all)
  • MCEdit says there are no chunk errors but does say the dimensions are 30,017,296L x 30,010,864W x 256H which is crazy.
  • I used a utility to trim the map to 30K x 30k but MCEdit still says it is 30M square.

Do you know of any utilities that can scan the map for additional problems? I know there are many redstone projects on the server but I am unsure if these are the cause.

0

Well, if you are running on your computer, localhost, then you could have it running on 2GB of RAM and you're computer can't handle it. Chunk and map loading can't really be changed and edited, you could always look at a plugin that stables the map loading. It's called NoLagg.

2
  • It is a dedicated server in a Texas Data center with 2x Quad Core opterons, 8GB ram. The server has been running Minecraft fine for over a year. I tried NoLogg on my local machine with the same map and it does not help. Nov 16 '13 at 22:20
  • That almost sounds like something is wrong on the servers end. List all the plugins you use?
    – MatthewH
    Nov 17 '13 at 6:24
0

It turns out it has something to do with the new "structures" files in the data folder. I deleted the mineshafts file for now and the RAM usage went back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.