3

Is there a way to turn off animals in creative mode in minecraft? I have world edit installed.

0

5 Answers 5

3

Set the game rule doMobSpawning to false.

/gamerule doMobSpawning false

3

You don't even need WorldEdit: just type /gamerule doMobSpawning false, and then type kill @e to kill everything that's alive. Once you respawn there will be no animals or mobs left.

2

You can use the WorldGuard mob-spawning flag:

/region flag __global__ mob-spawning deny

Using: WorldEdit and MV 2.5 b641

3
  • 1
    requires worldguard and the region is __global__
    – 3ventic
    Commented Nov 17, 2013 at 19:28
  • What is mv? Where do I download it. Without it I get command not found.
    – Ari Porad
    Commented Nov 17, 2013 at 19:57
  • @AriPorad You'll need WorldGuard for this, not Multiverse.
    – grg
    Commented Nov 19, 2013 at 22:26
0

It turns out I was not playing on peaceful mode, when you do that, all the animals go away.

2
  • 6
    Um, animals still spawn on peaceful. Only hostile mobs are removed...
    – MBraedley
    Commented Nov 17, 2013 at 21:44
  • @MBraedley, I don't know, but I am playing in creative mode, cheats enabled, peaceful, and not letting it get dark, and no animals.
    – Ari Porad
    Commented Nov 19, 2013 at 23:50
-2

The following command stops spawning naturally:

/doMobSpawning false
1
  • 1
    Does that apply to animals as well, or just enemy mobs?
    – IQAndreas
    Commented Jan 10, 2014 at 18:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .