1

I recently tried to get back to playing Kingdoms of Amalur: Reckoning on my PS3 after a year-long break and I've run into a strange glitch (as I think of it now, it might have been a reason I stopped playing the game).

Whenever I try to move my character he takes a couple of steps and just freezes mid-step, for as long, as I hold the stick forward.

Only ways to keep moving are:

  • change direction of the stick (not always works),
  • use dodge to tumble forward,
  • release the stick, and move it again.

Please note it's not the question of the game lagging or freezing; it's only my character that stops moving. I'm also sure my controllers (both of them) work fine - I have no problems in any other game with proper functioning of left stick.

I tried to do a search for possible solutions to this bug, but apart from finding some evidence of more people experiencing it, I had no luck. There were mentions of using a save from before the bug appeared, but it's not a solution, really.

Has anyone run across something similar? Is there a solution to this, that would let me continue playing my current save?

3
  • Does the problem persist after fast traveling?
    – CyberSkull
    Nov 19 '13 at 0:05
  • @CyberSkull Yes it does. I should also note, that I tried deleting the files installed on PS3's HDD (~3.5GB) and reinstalling the game too - still no change.
    – ykb
    Nov 19 '13 at 7:58
  • This sounds familiar, but I probably rolled back to a much earlier save.
    – CyberSkull
    Nov 19 '13 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.