6

Last Year, I bought Grand Theft Auto IV on Steam (PC). After I installed it I played it for less that an hour, then I had to go out. The next day the game would not launch. The Launcher would appear, but when I press the 'Play' button, the loading cursor would appear for about 5 seconds, then disappear. No boxes would come up, and no related processes would be running. I have reinstalled the game several times since then but the same thing has happened ever since. I'm running Windows 7 64-bit.

9

Run as Administrator

First, completely exit Steam, and right-click on the shortcut which you use to launch Steam and select "Run as Administrator." This step may be enough to fix the problem. If not, continue below:

Additional Installers

You may need to manually run secondary installers required by this game. Exit Steam entirely. Browse to your Grand Theft Auto 4 installation folder (Usually C:\Program Files\Steam\steamapps\common\grand theft auto iv\)

You will need to run each of the following installers:

...\steamapps\common\grand theft auto iv\Installers\DirectX_jun2008\DXSETUP
...\steamapps\common\grand theft auto iv\Installers\DirectX_Mar2009\DXSETUP
...\steamapps\common\grand theft auto iv\Installers\vcredist_x86

Games for Windows Live

Also, install the latest version of the Games For Windows Live software, which can be found here: http://www.microsoft.com/games/en-US/Live/Pages/livemarketplace.aspx

Restart your computer and test the issue again. If you continue to have difficulty, run this installer:

...\steamapps\common\grand theft auto iv\GTAIV\Activation\SteamActivation 

References

Taken from this steam forum post. In addition, there is another thread of a huge list of GTA IV steam issues which you can find here.

| improve this answer | |
2

If your GTA 4 is not running anymore, download and install the Windows Live Client.

This solved it for me.

| improve this answer | |
  • 1
    @Oak Pretty much cleaned/censored my post there. Maybe a little too much? – Sander Apr 8 '12 at 14:44
  • 1
    I understand your frustration - I'd get pretty frustrated if my games stopped running - but rants are not really useful and we generally try to remove them. – Oak Apr 8 '12 at 15:04
  • @Oak Ok, thanks for your reply and also understanding. – Sander Apr 8 '12 at 15:17
1

Internet Explorer 9 (beta version) prevented GTA IV from launching for me as well. There were no error dialogs about what happened. Uninstalling the IE9 beta fixed the problem for me.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.