I found a batch file that works for launching Minecraft under my proxy it is:

java -Dhttp.proxyHost=localhost -Dhttp.proxyPort=80 -Dhttps.proxyHost=localhost -Dhttps.proxyPort=443 -DsocksProxyHost=localhost -DsocksProxyPort=1080 -Xmx800m -jar Minecraft.exe

I was wondering how I could launch the Raptr Desktop app under the same proxy using this or another batch file.

Raptr is located in C:\Program Files\Raptr\raptr.exe

| improve this question | | | | |
  • 2
    Minecraft works because it uses Java. Raptr is an executable, and if it doesn't support proxies, it won't through a batch file. – Frank Nov 19 '13 at 20:51
  • Have you tried looking through the app itself? Or asking Raptr's Support? – Cole Busby Nov 19 '13 at 21:01
  • I have tried looking at Raptrs pages and someone asked this before and didn't get a successful answer. Is there any way to edit the script to make it work for .exe's? – Dragonpwnsz Nov 19 '13 at 21:47
  • It works for Minecraft because it supports it. Unless Raptr supports command line proxies, no, there is no way to make it work. – Frank Nov 19 '13 at 22:18
  • 1
    An executable is just an compilation of programming code made into a form readable by the computer. If the programmer(s) decided not to implement a function, then the exec wouldn't contain the function either. Hope this helps. Keep up the questioning with Raptr support. – deutschZuid Nov 20 '13 at 0:58

After some googling,

Raptr has stated that it officially does not support proxy servers natively, however there are ways to have specific programs use a proxy if they do not natively support it. Superuser is where this question is best answered as it falls more into their scope of things than ours, so there is the link to a supported answer with programs that do what you want to do.

There are also some other Windows Users having a similar issue regarding proxies for the whole system.

There is also some talk that if you set the proxy server in IE that it would carry over to some programs but this is untested.

Raptr DOES NOT support command line proxy settings.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.