0

I've downloaded both the 1.7.2's for the game itself and the multiplayer server. When I click on minecraft_server.1.7.2 the application won't even open, it'll load up logs but nothing else, it won't bring the minecraft server page up. I have also tried running it in admin mode, nothing changed. What am I doing wrong?

server screenshot

This is what I'm trying to open but when I click on the application it won't even load, it'll just bring up logs. It won't load world, banned-ips, banned-players, ops, server, or white-list.

  • 3
    Try running it in administrator mode. What minecraft server page are you talking about? – Quaxton Hale Nov 20 '13 at 21:25
  • Have you attempted to run the .jar version of the server through a batch file. There are instructions in the minecraft website. – ReallyGoodPie Nov 21 '13 at 1:09
  • That looks like the server is starting up fine. Just leave it for a few minutes and then try to connect to it. – MBraedley Nov 21 '13 at 11:56
  • In the latest versions, logs are empty for some reason for me, though the server itself works okay. – Orc JMR Nov 21 '13 at 14:43
3

Attempt to launch the jar with a batch file.

This can be created by opening notepad and typing the following,

java -Xmx2G -Xms2G -jar minecraft_server.1.7.4.jar -o true
pause

Save this file as launcher.bat, and store it in the same directory as your jar file.

This should now launch the server. Good luck!

1

Take a look at the top of your screenshot. It says Minecraft Server Version 1.2.5. You may have downloaded an old version and/or simply saved it in the wrong location. Download the server jar from the official minecraft site if you have gotten it from another source. Also, consider using a startup script (batch file if in Windows) to run your server instance, as outlined by many "how-to's" in many google searches.

Edit: apparently that isn't actually your screenshot, after re-reading the question. The portion of my answer concerning using a startup script still stands. Other possibilities exist.

  1. Make sure nothing on your system is already bound to the default port of 25565.
  2. Make sure you have Java installed (and the appropriate version)
  3. Make sure you have enough RAM available for the application to run.

Also, post your server.log file, it will present information that might be more useful for debugging.

0

Rather belated, but I had a similar issue with 1.7.10 - initially the server wouldn't start - a /logs/ folder and an eula.txt file had been created.

Opening the eula.txt file resulted in:

#By changing the setting below to TRUE you are indicating your agreement to our
 EULA (https://account.mojang.com/documents/minecraft_eula).
#Mon Jun 30 12:37:28 UTC 2014
eula=false

Changing the last line to:

eula=true

Allowed the server to start.

As Orc_JMR notes in his comments, I'm not seeing anything in the "Log and chat" section but commands are accepted and players are listed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.