2

I'm getting this message from league of legends when I try to start the game:

There is an error connecting with Maestro. League of 
Legends will now exit.  Please try restarting the client.

This is prior to login. How does one debug this issue?

I've tried:

  • "turning it [my computer] off and on again."
  • running in admin mode for windows 7.
3
  • Are you using a firewall or antivirus software? If so, disable them and see if that fixes it.
    – TZHX
    Nov 21, 2013 at 6:07
  • I disabled my firewall and I don't have anti-virus. Nov 21, 2013 at 6:45
  • Why the downvote? I could happen to anyone.
    – Arkl1te
    May 12, 2014 at 12:37

4 Answers 4

1

Running the lol.launcher.admin.exe binary worked. I couldn't run the normal lol.launcher.exe manually in admin mode. I had to specifically launch lol.launcher.admin.exe which was in my c:/Program Files/Leage of Legends directory on my Windows 7 machine.

1

Hello I have had this error before and there are a number of reason why you maybe having it however there are foursimply things you can do to fix it first off

  1. You need to allow league of legends in your firewall.
  2. You can also DELETE on your "League of Legends\RADS\projects\lol_air_client\releases\0.0. 0.249\deploy" the lolclient.exe file. this generally is the best way to fix it it.
  3. Restarting your PC can also fix this however logging off and on has more or less the same effect sometimes try this out first then restart if you are in a game though then just restart your PC.
  4. This is the last possible way to fix it but you may need to update your adobe air file manually. There are some people on YouTube who will give you their Skype id's and share the file with you just search for them. All this in mind though be sure not to delete your entire lol projects folder you want to specifically delete the lolclient file it will be re-downloaded by your lol patcher and you should not have any problems
1

You cannot launch from a taskbar pin. You must run League of Legends from the default .exe. No shortcuts. Not sure why, but this finally fixed this for me.

0

Restart your computer and relaunch the game.

sources: personal experience

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .