4

So I just installed Batman Arkham Asylum and I got this error at starting it:

enter image description here

When I click Quit, It will just stop launching.

When I click Continue, It will go to a small Batman window with 6 options which I cant see because it's pitch black. When I choose one of the options I get this:

enter image description here

What have I done wrong?

3

List of possible fixes starting from the simplest.Based on positive feedback from steam forums:

  1. Simply running the game .exe directly from the Steam\SteamApps\common\batman folder instead from steam application.

  2. Running BmLauncher.exe in `Steam\SteamApps\common\batman\ folder in windows 7 compatibility mode.

  3. As TZHX mentioned downloading and installing this direct x runtime

  4. Running following installers from Steam\SteamApps\common\batman\redist\ folder DXSETUP.exe, vcredist_x86.exe , PhysX_9.08.14_9.09.0814_SystemSoftware.exe

    • (Removing other versions of Direct X and PhysX might be necessary,best done before installing those from batman folder,problem is that if you uninstall newer version of PhysX or DirectX some newer games could stop working until you reinstall the new versions).
  5. Remove all installations of .NET framework (through the Start > Control Panel > Programs and Features,or even better some software removal tool) and install .NET framework 4.Some people say that you will have to reinstall the game itself,but It seems unnecessary to me.

    • If you use windows 7 or newer with required updates you can look in Start > Control Panel > Add remove windows features where you can select .NET framework version you want without having to download and install.
0

My first recommendation would be to reinstall .net framework and make sure you get the latest version. If that doesn't work, I am not sure. But that is the first thing I would try, in case there were errors during installation.

0

My Advise is that download nvidia physx http://www.softpedia.com/dyn-postdownload.php?p=104790&t=0&i=1 worked for me :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.