I just installed Forge 1.6.4 on Minecraft 1.7.2 but it is not working. Every time I start it crashes. I am running the game in release version 1.6.4 - Forge 9.11.1.953, which I selected through profile editor after installing forge but I am still getting these errors:

---- Minecraft Crash Report ----
// Why did you do that?

Time: 12/4/13 10:32 AM
Description: Initializing game

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:244)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:449)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:808)
at net.minecraft.client.main.Main.main(SourceFile:101)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
at net.minecraft.launchwrapper.Launch.main(Launch.java:27)


A detailed walkthrough of the error, its code path and all known details is as   follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:244)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:449)

-- Initialization --
Details:
Stacktrace:
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:808)
at net.minecraft.client.main.Main.main(SourceFile:101)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

-- System Details --
Details:
Minecraft Version: 1.6.4
Operating System: Windows 7 (x86) version 6.1
Java Version: 1.6.0_25, Sun Microsystems Inc.
Java VM Version: Java HotSpot(TM) Client VM (mixed mode, sharing), Sun       Microsystems Inc.
Memory: 31779448 bytes (30 MB) / 78983168 bytes (75 MB) up to 518979584 bytes (494 MB)
JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx512M
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Suspicious classes: FML and Forge are installed
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: 
Launched Version: 1.6.4-Forge9.11.1.953
LWJGL: 2.9.0
OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
Is Modded: Definitely; Client brand changed to 'fml,forge'
Type: Client (map_client.txt)
    Resource Pack: Default
    Current Language: ~~ERROR~~ NullPointerException: null
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
  • Try reinstalling Forge on a clean install of Minecraft, though keep in mind, when it says "Forge 1.6.4", that means it's meant for Minecraft 1.6.4. So make sure you match up the versions. If that doesn't work, try running a clean vanilla install. There might be some deeper issue here. Hard to say for sure. – Unionhawk Dec 4 '13 at 5:28
  • Forge 1.6.4 won't work for versions 1.7.x - Mojang significantly changed the game code for 1.7 and the things which Forge depends on - MCP for example, are still dealing with the changes. – shanodin Dec 14 '13 at 3:25
up vote 7 down vote accepted

Have you installed the latest drivers for your graphics card? And also, you might want to upgrade to a newer version of Java, such as version 7, as version 6 is very old.

One last thing, Forge 1.6.4 means it's only compatible with Minecraft 1.6.4.

  • i was able to play minecraft 1.7.2 until i installed forge now i cant play even minecraft even without forge it crashes again and again any idea about it – Dimensionless Dec 4 '13 at 5:46
  • @Akash Do a totally clean install of Minecraft. Installing Forge 1.6.4 on Minecraft 1.6.4 probably messed everything up. – Unionhawk Dec 4 '13 at 6:05
  • 1
    @Unionhawk Did you mean 1.7.2, instead of 1.6.4? – RavenM Dec 4 '13 at 14:52
  • @RavenM Yes... facepalm I thought that was what I said. – Unionhawk Dec 4 '13 at 14:58
  • i did re installed it again but nothing happened it still crashes – Dimensionless Dec 5 '13 at 4:05

OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.

I had the same problem a few months ago. This is what I tried, and it worked.

  • Do a clean install of Minecraft and install Forge again.
  • Install the latest version of Java
  • Upgrade video drivers (Seems to be the solution to many)
  • Restart your computer

Try and take out all the mods from your Mods folder in .minecraft and then see if forge works. Some mods just aren't compatible.

P.S. You can't run Forge 1.6.4 in minecraft 1.7.2.

What exactly did you do when you did a "clean install"?

Replacing just Minecraft.exe will not fix these issues.

I am assuming you did not delete the .minecraft folder.

Two possible fixes.

  1. Reset the minecraft version in your current profile
    • Change Use version: from 1.6.4-Forge9.11.1.593 to Use Latest Version.
  2. If fix 1 does not work, you need to delete .minecraft.
    1. Type %appdata%/.minecraft into the search box in the start menu, and press enter.
      • You should now be in either %appdata%/.minecraft or
        C:\Users\[Username]\AppData\Roaming\.minecraft
    2. If you want to keep saves/texturepacks/resourcepacks/screenshots, make a copy of them.
    3. Delete everything in .minecraft
    4. If you made copies in step 2, copy them back.
    5. Run the minecraft launcher.
      • You will be asked to log in again.
      • Launch minecraft.

The problem is that you're using Forge 1.6.4 for a version of Minecraft other than 1.6.4; that's why it's called 1.6.4. Almost every time Minecraft updates, the entire system is overhauled, and has majorly changed in every update; it's like trying to get a dog to lay an egg. Wait for a version of Forge to come out for 1.7.2 at: http://files.minecraftforge.net

just try this

trust me it should make it work

  • Please include a summary of the video in the post in case the video is unavailable in the future. – shanodin Jan 29 '15 at 10:47

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.