0

Up until a couple of hours ago, I could connect to my Hamachi server from another PC in my local network. But now I can't reach that server any more. In the server list it says "Can't connect to server". When I try to connect anyway, it says "java.net.ConnectException: Connection timed out: no further information" followed by the server's IP address.

The server is operating correctly - I believe - since I can connect with a client on that same computer. The server also hasn't got any mods running.

Hamachi apears to be working correctly too, the PC running the server shows up with a green icon saying "direct tunnel". I also moved my Hamachi connection up in the list to be the default connection. Didn't help. I've also restarting both Hamachi and the Hamachi network adapters, on both PCs.

Java is updated to the latest version on both PCs. There's also a firewall rule allowing both jre6 and jre7 to have inbound and outbound connections.

My logs aren't showing anything out of the ordinary either. Here's an example (that exception starting at line 2 has something to do with the console not showing anything, but that is a completely different matter.). I have tried connecting multiple times here:

[23:30:22] [Server thread/INFO]: Starting minecraft server version 1.7.2
[23:30:22] [Server console handler/ERROR]: Exception handling console input
java.io.IOException: De ingang is ongeldig
    at java.io.FileInputStream.readBytes(Native Method) ~[?:1.7.0_25]
    at java.io.FileInputStream.read(Unknown Source) ~[?:1.7.0_25]
    at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.7.0_25]
    at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.7.0_25]
    at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.7.0_25]
    at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.7.0_25]
    at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.7.0_25]
    at java.io.InputStreamReader.read(Unknown Source) ~[?:1.7.0_25]
    at java.io.BufferedReader.fill(Unknown Source) ~[?:1.7.0_25]
    at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_25]
    at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.7.0_25]
    at ll.run(SourceFile:78) [minecraft_server.1.7.2.exe:?]
[23:30:22] [Server thread/INFO]: Loading properties
[23:30:22] [Server thread/INFO]: Default game type: SURVIVAL
[23:30:22] [Server thread/INFO]: Generating keypair
[23:30:22] [Server thread/INFO]: Starting Minecraft server on *:25565
[23:30:22] [Server thread/INFO]: Preparing level "world"
[23:30:22] [Server thread/INFO]: Preparing start region for level 0
[23:30:23] [Server thread/INFO]: Done (1,039s)! For help, type "help" or "?"

Here's also my server.properties file:

#Minecraft server properties
#Fri Dec 06 23:30:22 CET 2013
generator-settings=
op-permission-level=4
allow-nether=true
level-name=world
enable-query=false
allow-flight=false
announce-player-achievements=true
server-port=25565
level-type=DEFAULT
enable-rcon=false
force-gamemode=false
level-seed=
server-ip=
max-build-height=256
spawn-npcs=true
white-list=false
spawn-animals=true
hardcore=false
snooper-enabled=true
online-mode=true
resource-pack=
pvp=false
difficulty=1
enable-command-block=true
gamemode=0
player-idle-timeout=0
max-players=20
spawn-monsters=true
generate-structures=true
view-distance=15
spawn-protection=16
motd=A Minecraft Server

Other answers also suggested using port-forwarding. Unfortunately, I can't use that. I'm using Hamachi so that I can host my server from wherever I am with my laptop.

EDIT: I reinstalled Hamachi on both PCs, and started a new Hamachi network, but still nothing.

  • Are connections to and from the server allowed through firewall? – 3ventic Dec 7 '13 at 0:56
  • @3ventic It used to work before, and I haven't personally changed any settings. To be absolutely certain, I added rules on my client for minecraft.exe and on my server for minecraft_server.1.7.2.exe. Nothing has changed. – Simon Verbeke Dec 7 '13 at 1:05
  • @3ventic Seems that adding the programs doesn't work. I added the specific port now, and I can connect. I still don't get why this happened (since I've been able to play without issues for the past 2 weeks), but at least it's fixed now. – Simon Verbeke Dec 7 '13 at 1:43
  • @SimonVerbeke Could you answer your own question below so it helps future users? – aman207 Dec 7 '13 at 6:25
  • @aman207 I was hoping 3ventic would add an answer, since he was the one to suggest this fix. But I'll add the answer. – Simon Verbeke Dec 8 '13 at 0:36