13

So, every time I start my PC this window pops up:

steam window

This even happens when Steam downloaded no update. What can I do to stop it from reappearing?

  • This window will always show up when Steam is started, period. There's no way to disable it. Is your problem that Steam is automatically trying to start when your PC boots up? – user98085 Dec 13 '13 at 14:36
  • 4
    That's not an update window. That's an installation verification window. – Frank Dec 13 '13 at 14:37
  • Related: How do I prevent the "Updating Steam" dialog from showing up TLDR: Run Steam with the -noverifyfiles command line option. – galacticninja Oct 22 '18 at 3:57
11

Steam will always check for updates on startup and download and install them automatically to ensure that you're running the latest version. Additionally, Steam will occasionally verify all of its files, to ensure that everything is as it should be. This is the window that you're getting.

This window is displayed while the update is installed or verification process is running to provide feedback to you (the user) that something is actually happening, rather than staying completely silent, leading you to think that the application hasn't started.

If the window appears every single time you start up Steam, you're probably experiencing an issue with Steam realising it has updated.

It's worth noting that this is a well discussed issue with no official solutions available, there are plenty of different suggestions on how this can be fixed though and some of these work for some of the people experiencing the problem some of the time, so you'll want to try all of them if you really want to stop Steam from verifying every time you start it.

Anti Virus/Internet Security applications

This issue can be exacerbated by anti-virus/internet security applications blocking Steam from doing what it wants to and reading all of Steam's files as the Steam application attempts to verify them. Try adding exceptions in these applications for your Steam folder and restart Steam to see if this resolves your issue.

Opt out of Steam beta

If you are a member of the Steam beta program, it might be worthwhile opting out of the beta program and reverting to a previous version of Steam (it should do this automatically) to see if this resolves your problem.

Steam not correctly closing when you shut down your PC

Another thing that is mentioned in the Steam forums, is allowing Steam to verify all of its files and then closing Steam properly (rather than letting Windows kill it as it shuts down). What you'd do here is wait however long it normally takes to verify files and get into the main Steam interface, and then close Steam with the menu option (or system tray icon) before restarting it. After restarting in this manner, the file verification window shouldn't appear, since Steam would have properly closed all of its files when it exited.

Performing a partial reinstall (keeping your games)

If you're certain this is not an issue with your anti-virus/internet security application and you haven't opted in to the beta, you can try one of the following to see if it resolves your problem:

  • Browse to your Steam folder
  • Delete all files except for:
    • steamapps folder
    • userdata folder
    • Steam.exe file
  • Restart your computer
  • Browse to your Steam folder
  • Run Steam.exe to reinstall the game

This will essentially reinstall Steam without requiring you to redownload all of your games or losing any of your locally stored settings.

What to do if none of this works

If you're still having problems after trying all of the above, there are really only two options;

  • Fully uninstall and reinstall Steam (note: This will delete all of your games, it is not a "full reinstall" if you back up your games as there are a few files in the steamapps folder that aren't game related)
  • Contact Steam Support
  • They should do that in background... or make an option to run it in background. – Braiam Dec 13 '13 at 14:32
  • 1
    Yes, but this window pops up at EVERY single startup and seems to be stuck. – Andalur Dec 13 '13 at 14:32
  • 7
    @Andalur that isn't what your question says... Please edit your question to specify exactly what the problem is with all of the information about the issues experienced, your intentions, what you actually need help with, etc, so that we can answer it – kalina Dec 13 '13 at 14:33
  • Even after delete->restart->update->restart the window is still there... – Andalur Dec 13 '13 at 14:59
  • If you are a member of the Steam beta program, it might be worthwhile opting out of the beta program and reverting to a previous version of Steam (it should do this automatically) to see if this resolves your problem. – kalina Dec 13 '13 at 15:05
2

A lot of falsehoods and general misinformation in this thread... This window absolutely CAN be permanately disabled while starting up Steam, period, end of story.

Open up the developer console and type:

"runtime verification: 0" and press Enter.

This will prevent the update script from running and skip to starting Steam straight away. Note, you'll need to do this once for each install path of steam (for those who have multiple Steam installations).

An alternative method is to edit the registry entry for "ActiveProcess" > "Active User" right click > 'modify' and change the value to 0. Not recommended unless you know what you're doing.

  • what is the developer console on windows? the only developer console i know of are in browsers which makes no sense here – Memor-X Jan 29 '18 at 0:35
  • Open up your Steam application and look at the second to top row of links ('Steam', 'Library', 'Community', etc). The last one will be 'Console' (you may need to opt into the Steam beta for it to appear). That is where you go, it has nothing to do with your internet browser. – Echo Jan 29 '18 at 0:39
  • That is the same console within Steam, whenever Fallout or Skyrim update thereby breaking F4SE or SKSE and I want to rollback to an earlier exe version. In order to access the Steam console, change the steam shortcut to accept a command line argument of -console. – Lore Friendly Jan 29 '18 at 3:40
  • I run command: runtime verification: 0 and steam console said: >>> command not found: runtime. Did I do something wrong? – 123iamking Aug 7 '18 at 6:52
1

I ran into this pattern when I realized that all my computer boots were only because of an unplanned, interrupted reboot. In other words, my computer BSOD'd while Steam was sitting there running in the background in the System Notification Area. This validation, I concluded, was just a sanity check to be sure that the unexpected killing of Steam didn't corrupt any of its files.

0

The simplest and absolute guarantee to prevent steam from updating at startup on windows 10 is to:

1: Right Click Toolbar

2: Select Task Manager

3: Open Tab Startup

4: Change Status of Steam Client Bootstrapper to Disabled

5: Reboot Computer to test it out

0

I'd been having that issue for a long while now and recently Steam got stuck in an endless loop of claiming to update itself only to prompt again at it's next launch. I can't promise this will work for everyone.

  1. Locate your Steam install folder (E.g: C:\Program Files (x86)\Steam)
  2. Right-Click the Steam and select Properties
  3. Select the Security tab and click Advanced
  4. Select the Owner tab and click Edit
  5. If present, click your username and skip to 8
  6. If not, click Other users or groups..
  7. Enter your username and click Check Names then OK
  8. Check Replace owner on subcontainers and objects and hit OK/Apply

Windows will then set permissions on all the files in the folder (this might take a bit) and once done Steam should no longer display the annoying update message on start.

  • Careful, people! This action might take over 20 minutes and I doubt this solution is kosher, let be working. Look for another solution first...If you cancel it midway, it can give a lot of trouble! – e-motiv Dec 23 '18 at 12:55
-1

With Steam open, click the Steam menu, and choose Settings.
Click on the Interface tab, and uncheck the box that says:

"Run Steam when my computer starts."
https://support.steampowered.com/kb_article.php?ref=5344-QWBN-3580

  • Yes, but I want that steam starts on every startup but I don't want this window. – Andalur Dec 13 '13 at 14:26
  • 1
    steam will check for update as soon as its starts and cant be turned of – Guus van Walstijn Dec 13 '13 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.