2

I tried to play Super Mario Galaxy 2 on my laptop, with the dolphin emulator. Unfortunately it won't play over 20-30 fps and is very laggy. Also the speed is too slow. It's the same with GameCube, the speed is, I guess like 50-70% of what it should be, but not more.

Maybe you have some tips for me?

Pc-Specs:

  • OS: Windows 8.1
  • CPU: Intel Core i7 3635Q (Quad Core, up to 3.4 GHz)
  • GPU: AMD/ATI Radeon 8870m
  • RAM: 8GB 1600mhz (don't know more about it xD)

And yes, I enabled everything I should for this game, the PC-settings are on high performance, all drivers are updated.

The strange thing is, that it doesn't matter if I play it on the lowest resolution with low settings or the highest resolution with AA, AF, etc., it always runs that slow.

  • Emulation depends mostly on CPU power. Have you tried setting Emulation > Frame skipping to some value above 0? I don't recommend setting it too high, but increasing the value usually helps making the game run faster. – Nolonar Dec 15 '13 at 17:29
  • Please do not enable OpenCL Texture decoder. It may cause issues or in some cases-"Dolphin.exe has stopped working. – user108483 Apr 16 '15 at 14:01
  • Make sure that you're not using the integrated GPU; SMG2 is a game that uses a lot of CPU and GPU power, so you should make sure you're using the discrete card and not the iGPU. – Léo Lam Jun 21 '15 at 7:47
1

The main fork of Dolphin isn't optimized for running Super Mario Galaxy 2. You should try this:

Make sure you have - The latest stable build of Dolphin (64-bit if you have a 64-bit machine) - AA CPU with SSE2 support.

then

Turn off/lower to minimum

  • Limit by FPS
  • DSP on Dedicated Thread
  • V-Sync
  • Log FPS to file
  • Ignore Format Changes
  • Anti-aliasing
  • Anisotropic filtering
  • Post Processing effect
  • graphics options: Advanced tab: all checkboxes
  • DPSLLE on Separate Thread

Turn On/raise to maximum

  • Optimize dolphin settings. (Online resources: FAQ, SMG2, Wiki Manual, Performance Guide)
  • Use DirectX if possible
  • Internal Resolution: 1x Native (640x528)
  • Rightclick Game Window -> Properties -> Alternate Wiimote Timing
  • Config -> Enhancements -> Enable Scaled EFB Copy (may be unnecessary)
  • Enable Dual Core
  • Set CPU Emulator Engine to JIT or JITL (if latter may has issues, use JIT
  • Enable Idle Skipping
  • Force Texture Filtering
  • Disable Fog
  • Per-Pixel Lighting
  • Set EFB copies to Texture
  • Set Texture Cache to Fast
  • Cache Display List (may crash, try and on and off)
  • Disable Destination Alpha (may crash, try and on and off)
  • OpenMP Texture Decoder (in rare instances it can "max out all cores" and hurt more than it helps)
  • Fast Depth Calculation (may cause flickering textures, try on and off)
  • OpenCL Texture Decoder
  • Fast Depth Calculation
  • OpenMP Texture Decoder
  • Vertex Streaming Hack
  • DPS LLE Recompiler
  • XAudio2
  • Reduce detail in your graphics card settings to improve performance.
  • Hide mouse cursor
  • DSP Emulator engine to DSP HLE Emulation (fast, but you may encounter audio glitches, if so, you may want to switch to DSP LLE Recompiler which is slower but more accurate)
  • If using DSP, use this guide to dump DSP files with a Homebrew-enabled Wii (if you have a Wii, that is)
  • Game Config: Speed up disc transfer rate

or

  • Try another fork or unstable build of dolphin
  • Repeat the dolphin setting optimization for that build.

or

  • Get overpowered hardware to cope with running the software.
  • Sorry, I have updated the answer. – Hiccup Apr 13 '14 at 14:04
  • There is no need to delete your complaining comment, it was perfectly reasonable :P – Hiccup Apr 17 '14 at 13:25
  • I've come back to this answer, and I've realized it is really bad. This is just general advice for dolphin. It might slow down SMG2 to a halt. Some better advice: (1) read the dolphin wiki for SMG2 (2) try different things out, one at a time, to see if anything speeds it up, but always write down your previous settings (3) try out settings that have worked for other people, but always write down your previous settings, and try one thing at a time, if possible – Hiccup May 27 '15 at 11:39
  • You can edit your answer to include this updated info – Stevoisiak May 17 '17 at 1:09
-3

whenever the framerate goes below 60 in graphically demanding areas, Vsync brings framerate to 30fps resulting in the game running at half the speed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.