6

When I play Minecraft, I sometimes connect my TV and play a video (a TV show or a YouTube video) and I set the default output device to the TV speakers, but I don't want Minecraft audio to merge with that. I would rather have it come out of the PC speakers.

Is there a way to change the output device for just the one program or to change the output device with Java?

5

Minecraft doesn't support outputting audio via a specific audio device. With the diversity of the actions whose audio you want to send to your TV you're probably going to experience issues making it work as you want to.

For watching movies or TV shows that exist as data on your PC, you could swap the media player you're using to one that supports outputting audio to a specific device rather than the Windows default device.

This would mean setting your PC's audio device as the windows default device so that Minecraft uses it, and then manually setting your media player to use the other audio device.

VLC supports outputting to a specific device using the "DirectX Output" audio module, available under audio in preferences. This would allow you to play media files and output audio to your TV while running Minecraft outputting audio over the default sound device.

This won't work for YouTube however, and web browsers, like Minecraft, do not have the option to output to a specific audio device, so there wouldn't be a workaround for this.

  • 3
    there may be a solution over on superuser.SE for managing sound streams – ratchet freak Dec 18 '13 at 16:30
5

I found a solution. I don't know if this will work for everyone but I found a bug exploit that worked. Minecraft doesn't like when you change default devices while it is running. It wants to stay in that default channel. So run Minecraft first and then plug in the TV, change the default device, and you will have the audio coming out of two different sources.

TL;DR Run Minecraft first, then change default sound device.

  • 2
    Not necessarily a bug, a lot of games and applications that don't offer an audio device selector will lock their audio device on launch. i.e. this works with Skyrim too. – user73272 Jul 26 '16 at 0:43
4

Load/Change a Resource Pack in-game and for some reason, it causes Minecraft to switch to the default audio output!

Let me know If it works for you.

  • That's fantastic! Don't know why it works, but it's great. I just created a basic blank resource pack (just the mcmeta file and an empty assets folder), so it loads and unloads quickly, and it fixes the audio issue. – TheRotag Mar 16 '19 at 19:30
0

if your using an HP computer then go into the sound settings and scroll down and below the troubleshoot option you will see "App volume and device preferences", click there and you should be able to choose what apps use what output and input devices.

i had a similar issue where my Minecraft audio would play through my computer speakers and everything else played through my Beats so I had to change it so everything plays through my beats

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.