6

I recently tried KMQuake2 (Knightmare Quake II) and it works very well for playing Quake 2.

However, it doesn't support widescreen resolutions (16:9), like 1920 x 1080 - it only supports 4:3 resolutions, like 1280x1024, 1400x1050, 1600x1200, etc.

Is there any any way to run KMQuake2 in a widescreen resolution?

Additionally, the KMQuake2 homepage doesn't have any support page or contact, any idea how I can contact the author so I can send a feature request?

1
  • The developer's email address is in a link buried in the news page and appears to be knightmare66 @ yahoo . com
    – kalina
    Dec 18 '13 at 18:19
7

To set a widescreen resolution, you will need to manually define a custom resolution for the game to run at. This will require editing the games configuration files.

First of all, you need to make sure the configuration files exist - this is done by starting each game (and each expansion if you have any) at least once, and then exiting.

Inside your Quake 2 folder in the "baseq2" folder, edit the file kmq2config.cfg and find the following lines:

set r_customheight "xxxx" set r_customwidth "xxxx"

Change these two lines (the xxxx) to define the resolution you wish to run at. For example, if you want to use 1920x1080, set r_customheight to "1080" and r_customwidth to "1920". Be careful not to get these the wrong way around.

Then, find this line:

set r_mode "x"

This is the line that defines which built in resolution option is active. Set this to "-1" to enable your custom resolution.

If you find after making these changes that your field of view is weird or not how you'd like it, find the following lines to adjust your FOV:

set cl_widescreen_fov "x"

Set this to "0" to disable the FOV auto-adjust. Then, find this line:

set fov "x"

Change this to the FOV (in degrees) that you want, save your configuration file, and run the game. If you need assistance working out what field of view you should be using at your resolution, you can use the Field Of View Calculator on the Widescreen Gaming Forums to work it out for you.

2
  • is my memory correct: mode -1 is 16:9, and mode -2 is 16:10 (?)
    – horatio
    Dec 18 '13 at 22:27
  • works very well, without playing with fov parameters. Thanks!
    – BearCode
    Dec 19 '13 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.