7

I've got a right tack monitor layout, and the vertical monitor is the main one. This makes for rather odd graphics settings in Rogue Legacy:

  • Only vertical resolutions are displayed, up to 1200x1920.
  • Even at full resolution there are large black gaps at the top and bottom of the screen.
  • Fullscreen mode always goes to the vertical monitor.

Is there some way to force Rogue Legacy to display on the horizontal monitor, and to use the resolutions available for that screen?

I had a look in ~/.config/RogueLegacyStorageContainer/GameConfig.ini. I can set the resolution to 1920x1200, which works sort of OK in windowed mode, but there's no mention of which monitor to use.

1

Here are some things to try:

If the game uses SDL, it is possible to set which monitor fullscreen games will run in by setting an environment variable like so:

export SDL_VIDEO_FULLSCREEN_HEAD=0

Which you could stick into your preferred userland environment file, depending on your flavor of linux and shell.

or maybe

Adding the following line to /etc/environment.

SDL_VIDEO_FULLSCREEN_DISPLAY=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.